Full-featured XMPP client written in Python and Gtk2

The goal of Gajim is to provide a full featured and easy to use Jabber/XMPP client. Gajim works nicely with MATE or GNOME, but does not require neither to run.

Features:
* Tabbed chat window and single window modes
* Group chat support (with Multi-User Chat protocol), invitation, chat to group chat transformation, minimize group chat to roster
* Emoticons, avatars, PEP (user activity, mood and tune)
* Audio / video conferences
* File transfer, room bookmarks
* Metacontacts support
* Trayicon, speller, extended chat history functionalities
* TLS, GPG and End-To-End encryption support (with SSL legacy support)
* Transport registration support
* Service discovery including nodes, user search
* Wikipedia, dictionary and search engine lookup
* Multiple accounts support
* DBus capabilities. Read more information
* XML console
* Link local (bonjour / zeroconf), BOSH
* Other features via plugins

Refresh
Refresh
Source Files
Filename Size Changed
gajim-1.2.2.tar.gz 0009416794 8.98 MB 5 months
gajim.changes 0000021850 21.3 KB 11 days
gajim.spec 0000004454 4.35 KB 11 days
Comments for gajim 4

Diabolic Preacher's avatar

dpreacher wrote 5 months ago

I hope this is the right way to approach with an issue with packaging for gajim. gajim 1.2.2 depends on python3-nbxmpp 1.0.2 and this can be confirmed both by running gajim from terminal as well as looking at /usr/lib/python3.8/site-packages/gajim/gajim.py line number 29 "_MIN_NBXMPP_VER = '1.0.2'".

However in gajim.spec as seen here, the Requires and BuildRequires for python3-nbxmpp is >= 0.6.9.

This is step one. After gajim package correctly requires 1.0.2, the python3-nbxmpp package itself has to be updated from 0.6.10 but I can't find the page to approach the maintainer.


Felix Knecht's avatar

felixknecht wrote 5 months ago

Same here. I emailed Dirk Mueller who is named in the changelog. No answer so far, but he put in the request to update nbxmpp: https://build.opensuse.org/request/show/831611


Felix Knecht's avatar

felixknecht wrote 5 months ago

And I just figured out where I should have reported this: https://bugzilla.opensuse.org/show_bug.cgi?id=1176101


Diabolic Preacher's avatar

dpreacher wrote 5 months ago

thank you for helping out with the reporting and the links. I see that the fix is already sent as a request to OBS. :)

openSUSE Build Service is sponsored by