D-BUS Service for Zeroconf and Bonjour

Avahi is an implementation of the DNS Service Discovery and Multicast
DNS specifications for Zeroconf Computing. It uses D-BUS for
communication between user applications and a system daemon. The daemon
is used to coordinate application efforts in caching replies, necessary
to minimize the traffic imposed on networks.

The Avahi mDNS responder is now complete with features, implementing
all MUSTs and the majority of the SHOULDs of the mDNS and DNS-SD RFCs.
It passes all tests in the Apple Bonjour conformance test suite. In
addition, it supports some nifty things, like correct mDNS reflection
across LAN segments.

Refresh
Refresh
Source Files
Filename Size Changed Actions
CVE-2018-1000845.patch 0000001578 1.54 KB 8 months
attributes 0000001666 1.63 KB about 10 years
avahi-0.6.32-suppress-resolv-conf-warning.patch 0000000926 926 Bytes about 3 years
avahi-0.7-dbm.patch 0000006882 6.72 KB 8 months
avahi-0.7-encode-strings-as-utf8.patch 0000002888 2.82 KB 8 months
avahi-0.7-python3-bookmarks.patch 0000004875 4.76 KB 8 months
avahi-0.7.tar.gz 0001333400 1.27 MB almost 2 years
avahi-autoipd.README.SUSE 0000003030 2.96 KB over 5 years
avahi-autoipd.if-down 0000000214 214 Bytes almost 7 years
avahi-autoipd.if-up 0000000325 325 Bytes almost 7 years
avahi-autoipd.sysconfig 0000000993 993 Bytes over 5 years
avahi-daemon-check-dns-suse.patch 0000002277 2.22 KB about 7 years
avahi-daemon-check-dns.sh 0000004188 4.09 KB about 7 years
avahi-daemon.if-up 0000000431 431 Bytes about 7 years
avahi-desktop.patch 0000001291 1.26 KB almost 7 years
avahi-gacdir.patch 0000004357 4.25 KB almost 9 years
avahi-glib-gettext.m4 0000013266 13 KB about 11 years
avahi-glib2.changes 0000003832 3.74 KB about 2 months
avahi-glib2.spec 0000044246 43.2 KB about 2 months
avahi-mono.changes 0000002912 2.84 KB about 2 months
avahi-mono.spec 0000044358 43.3 KB about 2 months
avahi.changes 0000047526 46.4 KB about 2 months
avahi.spec 0000044306 43.3 KB about 2 months
avahi.sysconfig 0000000296 296 Bytes about 7 years
avahi_spec-prepare.sh 0000001693 1.65 KB 4 months
baselibs.conf 0000000487 487 Bytes almost 8 years
pre_checkin.sh 0000000051 51 Bytes almost 12 years
update_spec.pl 0000002048 2 KB about 10 years
Comments for avahi 2

Repo Checker

repo-checker wrote over 1 year ago

The version of this package in openSUSE:Leap:15.0 has installation issues and may not be installable:

can't install libavahi-qt4-devel-0.6.32-lp150.2.3.x86_64:
  package libqt4-devel-4.8.7-lp150.6.5.x86_64 requires c++_compiler, but none of the providers can be installed
  package libavahi-qt4-devel-0.6.32-lp150.2.3.x86_64 requires pkgconfig(QtCore) >= 4.0.0, but none of the providers can be installed
  package libavahi-qt4-devel-0.6.32-lp150.2.3.x86_64 requires libqt4-devel, but none of the providers can be installed
  package gcc-c++-7-lp150.1.27.x86_64 requires gcc7-c++, but none of the providers can be installed
  nothing provides libmpfr.so.4()(64bit) needed by gcc7-c++-7.3.0+r257042-lp150.1.3.x86_64

Repo Checker

repo-checker wrote 10 months ago

The version of this package in openSUSE:Factory has installation issues and may not be installable:

can't install libavahi-glib-devel-0.7-4.3.i586:
  package gtk2-devel-2.24.32-6.1.i586 requires pkgconfig(pangocairo), but none of the providers can be installed
  package gtk2-devel-2.24.32-6.1.i586 requires pkgconfig(pango), but none of the providers can be installed
  package gtk2-devel-2.24.32-6.1.i586 requires pkgconfig(pangoft2), but none of the providers can be installed
  package pango-devel-1.42.4-1.1.i586 requires pkgconfig(harfbuzz), but none of the providers can be installed
  package libavahi-glib-devel-0.7-4.3.i586 requires pkgconfig(gtk+-2.0), but none of the providers can be installed
  package harfbuzz-devel-1.9.0-1.1.i586 requires libharfbuzz-icu0 = 1.9.0, but none of the providers can be installed
  nothing provides libicuuc.so.suse62.1 needed by libharfbuzz-icu0-1.9.0-1.1.i586

can't install libavahi-glib-devel-0.7-4.3.x86_64:
  package gtk3-devel-3.24.1-1.1.x86_64 requires pkgconfig(pangocairo), but none of the providers can be installed
  package gtk3-devel-3.24.1-1.1.x86_64 requires pkgconfig(pango), but none of the providers can be installed
  package gtk3-devel-3.24.1-1.1.x86_64 requires pkgconfig(pangoft2), but none of the providers can be installed
  package pango-devel-1.42.4-1.1.x86_64 requires pkgconfig(harfbuzz), but none of the providers can be installed
  package libavahi-glib-devel-0.7-4.3.x86_64 requires pkgconfig(gtk+-3.0), but none of the providers can be installed
  package harfbuzz-devel-1.9.0-1.1.x86_64 requires libharfbuzz-icu0 = 1.9.0, but none of the providers can be installed
  nothing provides libicuuc.so.suse62.1()(64bit) needed by libharfbuzz-icu0-1.9.0-1.1.x86_64

can't install libavahi-gobject-devel-0.7-4.3.i586:
  package gtk3-devel-3.24.1-1.1.i586 requires pkgconfig(pangocairo), but none of the providers can be installed
  package gtk3-devel-3.24.1-1.1.i586 requires pkgconfig(pango), but none of the providers can be installed
  package gtk3-devel-3.24.1-1.1.i586 requires pkgconfig(pangoft2), but none of the providers can be installed
  package libavahi-glib-devel-0.7-4.3.i586 requires pkgconfig(gtk+-3.0), but none of the providers can be installed
  package pango-devel-1.42.4-1.1.i586 requires pkgconfig(harfbuzz), but none of the providers can be installed
  package libavahi-gobject-devel-0.7-4.3.i586 requires libavahi-glib-devel, but none of the providers can be installed
  package libavahi-gobject-devel-0.7-4.3.i586 requires pkgconfig(avahi-glib), but none of the providers can be installed
  package harfbuzz-devel-1.9.0-1.1.i586 requires libharfbuzz-icu0 = 1.9.0, but none of the providers can be installed
  nothing provides libicuuc.so.suse62.1 needed by libharfbuzz-icu0-1.9.0-1.1.i586

can't install libavahi-gobject-devel-0.7-4.3.x86_64:
  package gtk2-devel-2.24.32-6.1.x86_64 requires pkgconfig(pangocairo), but none of the providers can be installed
  package gtk2-devel-2.24.32-6.1.x86_64 requires pkgconfig(pango), but none of the providers can be installed
  package gtk2-devel-2.24.32-6.1.x86_64 requires pkgconfig(pangoft2), but none of the providers can be installed
  package libavahi-glib-devel-0.7-4.3.x86_64 requires pkgconfig(gtk+-2.0), but none of the providers can be installed
  package pango-devel-1.42.4-1.1.x86_64 requires pkgconfig(harfbuzz), but none of the providers can be installed
  package libavahi-gobject-devel-0.7-4.3.x86_64 requires libavahi-glib-devel, but none of the providers can be installed
  package libavahi-gobject-devel-0.7-4.3.x86_64 requires pkgconfig(avahi-glib), but none of the providers can be installed
  package harfbuzz-devel-1.9.0-1.1.x86_64 requires libharfbuzz-icu0 = 1.9.0, but none of the providers can be installed
  nothing provides libicuuc.so.suse62.1()(64bit) needed by libharfbuzz-icu0-1.9.0-1.1.x86_64