LogoopenSUSE Build Service > Projects
Sign Up | Log In

mvapich2

No description set

Source Files (show merged sources derived from linked package)

Filename Size Changed Actions
0001-Drop-GCC-check.patch 1.71 KB Download File
_multibuild 345 Bytes Download File
macros.hpc-mvapich2 640 Bytes Download File
mpivars.csh 318 Bytes Download File
mpivars.sh 526 Bytes Download File
mvapich2-2.3.1.tar.gz 16.2 MB
mvapich2-arm-support.patch 926 Bytes Download File
mvapich2-s390_get_cycles.patch 931 Bytes Download File
mvapich2.changes 26.2 KB Download File
mvapich2.spec 13.2 KB Download File
reproducible.patch 3.62 KB Download File

Comments for science:HPC (1)

repo-checker wrote over 1 year ago

The version of this package in openSUSE:Leap:15.0 has installation issues and may not be installable:

can't install mvapich2-devel-2.2-lp150.4.1.x86_64:
  package mvapich2-devel-2.2-lp150.4.1.x86_64 requires gcc-fortran, but none of the providers can be installed
  package gcc-fortran-7-lp150.1.27.x86_64 requires gcc7-fortran, but none of the providers can be installed
  nothing provides libmpfr.so.4()(64bit) needed by gcc7-fortran-7.3.0+r257042-lp150.1.3.x86_64

can't install mvapich2-devel-static-2.2-lp150.4.1.x86_64:
  package mvapich2-devel-2.2-lp150.4.1.x86_64 requires gcc-c++, but none of the providers can be installed
  package mvapich2-devel-static-2.2-lp150.4.1.x86_64 requires mvapich2-devel = 2.2, but none of the providers can be installed
  package gcc-c++-7-lp150.1.27.x86_64 requires gcc7-c++, but none of the providers can be installed
  nothing provides libmpfr.so.4()(64bit) needed by gcc7-c++-7.3.0+r257042-lp150.1.3.x86_64

can't install mvapich2-gnu-hpc-devel-2.2-lp150.4.1.x86_64:
  package mvapich2_2_2-gnu-hpc-devel-2.2-lp150.4.1.x86_64 requires gnu-compilers-hpc-devel, but none of the providers can be installed
  package gnu-compilers-hpc-devel-1.3-lp150.4.1.noarch requires gcc-c++, but none of the providers can be installed
  package mvapich2-gnu-hpc-devel-2.2-lp150.4.1.x86_64 requires mvapich2_2_2-gnu-hpc-devel = 2.2, but none of the providers can be installed
  package gcc-c++-7-lp150.1.27.x86_64 requires gcc7-c++, but none of the providers can be installed
  nothing provides libmpfr.so.4()(64bit) needed by gcc7-c++-7.3.0+r257042-lp150.1.3.x86_64

can't install mvapich2-gnu-hpc-macros-devel-2.2-lp150.4.1.noarch:
  package mvapich2_2_2-gnu-hpc-devel-2.2-lp150.4.1.x86_64 requires gnu-compilers-hpc-devel, but none of the providers can be installed
  package mvapich2_2_2-gnu-hpc-macros-devel-2.2-lp150.4.1.x86_64 requires mvapich2_2_2-gnu-hpc-devel = 2.2, but none of the providers can be installed
  package gnu-compilers-hpc-devel-1.3-lp150.4.1.noarch requires gcc-c++, but none of the providers can be installed
  package mvapich2-gnu-hpc-macros-devel-2.2-lp150.4.1.noarch requires mvapich2_2_2-gnu-hpc-macros-devel = 2.2, but none of the providers can be installed
  package gcc-c++-7-lp150.1.27.x86_64 requires gcc7-c++, but none of the providers can be installed
  nothing provides libmpfr.so.4()(64bit) needed by gcc7-c++-7.3.0+r257042-lp150.1.3.x86_64

can't install mvapich2-psm-devel-2.2-lp150.4.1.x86_64:
  package mvapich2-psm-devel-2.2-lp150.4.1.x86_64 requires gcc-fortran, but none of the providers can be installed
  package gcc-fortran-7-lp150.1.27.x86_64 requires gcc7-fortran, but none of the providers can be installed
  nothing provides libmpfr.so.4()(64bit) needed by gcc7-fortran-7.3.0+r257042-lp150.1.3.x86_64

can't install mvapich2-psm-devel-static-2.2-lp150.4.1.x86_64:
  package mvapich2-psm-devel-2.2-lp150.4.1.x86_64 requires gcc-c++, but none of the providers can be installed
  package mvapich2-psm-devel-static-2.2-lp150.4.1.x86_64 requires mvapich2-psm-devel = 2.2, but none of the providers can be installed
  package gcc-c++-7-lp150.1.27.x86_64 requires gcc7-c++, but none of the providers can be installed
  nothing provides libmpfr.so.4()(64bit) needed by gcc7-c++-7.3.0+r257042-lp150.1.3.x86_64

can't install mvapich2-psm-gnu-hpc-devel-2.2-lp150.4.1.x86_64:
  package mvapich2-psm_2_2-gnu-hpc-devel-2.2-lp150.4.1.x86_64 requires gnu-compilers-hpc-devel, but none of the providers can be installed
  package gnu-compilers-hpc-devel-1.3-lp150.4.1.noarch requires gcc-c++, but none of the providers can be installed
  package mvapich2-psm-gnu-hpc-devel-2.2-lp150.4.1.x86_64 requires mvapich2-psm_2_2-gnu-hpc-devel = 2.2, but none of the providers can be installed
  package gcc-c++-7-lp150.1.27.x86_64 requires gcc7-c++, but none of the providers can be installed
  nothing provides libmpfr.so.4()(64bit) needed by gcc7-c++-7.3.0+r257042-lp150.1.3.x86_64

can't install mvapich2-psm-gnu-hpc-macros-devel-2.2-lp150.4.1.noarch:
  package mvapich2-psm_2_2-gnu-hpc-devel-2.2-lp150.4.1.x86_64 requires gnu-compilers-hpc-devel, but none of the providers can be installed
  package mvapich2-psm_2_2-gnu-hpc-macros-devel-2.2-lp150.4.1.x86_64 requires mvapich2-psm_2_2-gnu-hpc-devel = 2.2, but none of the providers can be installed
  package gnu-compilers-hpc-devel-1.3-lp150.4.1.noarch requires gcc-c++, but none of the providers can be installed
  package mvapich2-psm-gnu-hpc-macros-devel-2.2-lp150.4.1.noarch requires mvapich2-psm_2_2-gnu-hpc-macros-devel = 2.2, but none of the providers can be installed
  package gcc-c++-7-lp150.1.27.x86_64 requires gcc7-c++, but none of the providers can be installed
  nothing provides libmpfr.so.4()(64bit) needed by gcc7-c++-7.3.0+r257042-lp150.1.3.x86_64

can't install mvapich2-psm2-devel-2.2-lp150.4.1.x86_64:
  package mvapich2-psm2-devel-2.2-lp150.4.1.x86_64 requires gcc-fortran, but none of the providers can be installed
  package gcc-fortran-7-lp150.1.27.x86_64 requires gcc7-fortran, but none of the providers can be installed
  nothing provides libmpfr.so.4()(64bit) needed by gcc7-fortran-7.3.0+r257042-lp150.1.3.x86_64

can't install mvapich2-psm2-devel-static-2.2-lp150.4.1.x86_64:
  package mvapich2-psm2-devel-2.2-lp150.4.1.x86_64 requires gcc-c++, but none of the providers can be installed
  package mvapich2-psm2-devel-static-2.2-lp150.4.1.x86_64 requires mvapich2-psm2-devel = 2.2, but none of the providers can be installed
  package gcc-c++-7-lp150.1.27.x86_64 requires gcc7-c++, but none of the providers can be installed
  nothing provides libmpfr.so.4()(64bit) needed by gcc7-c++-7.3.0+r257042-lp150.1.3.x86_64

can't install mvapich2-psm2-gnu-hpc-devel-2.2-lp150.4.1.x86_64:
  package mvapich2-psm2_2_2-gnu-hpc-devel-2.2-lp150.4.1.x86_64 requires gnu-compilers-hpc-devel, but none of the providers can be installed
  package gnu-compilers-hpc-devel-1.3-lp150.4.1.noarch requires gcc-c++, but none of the providers can be installed
  package mvapich2-psm2-gnu-hpc-devel-2.2-lp150.4.1.x86_64 requires mvapich2-psm2_2_2-gnu-hpc-devel = 2.2, but none of the providers can be installed
  package gcc-c++-7-lp150.1.27.x86_64 requires gcc7-c++, but none of the providers can be installed
  nothing provides libmpfr.so.4()(64bit) needed by gcc7-c++-7.3.0+r257042-lp150.1.3.x86_64

can't install mvapich2-psm2-gnu-hpc-macros-devel-2.2-lp150.4.1.noarch:
  package mvapich2-psm2_2_2-gnu-hpc-devel-2.2-lp150.4.1.x86_64 requires gnu-compilers-hpc-devel, but none of the providers can be installed
  package mvapich2-psm2_2_2-gnu-hpc-macros-devel-2.2-lp150.4.1.x86_64 requires mvapich2-psm2_2_2-gnu-hpc-devel = 2.2, but none of the providers can be installed
  package gnu-compilers-hpc-devel-1.3-lp150.4.1.noarch requires gcc-c++, but none of the providers can be installed
  package mvapich2-psm2-gnu-hpc-macros-devel-2.2-lp150.4.1.noarch requires mvapich2-psm2_2_2-gnu-hpc-macros-devel = 2.2, but none of the providers can be installed
  package gcc-c++-7-lp150.1.27.x86_64 requires gcc7-c++, but none of the providers can be installed
  nothing provides libmpfr.so.4()(64bit) needed by gcc7-c++-7.3.0+r257042-lp150.1.3.x86_64

can't install mvapich2-psm2_2_2-gnu-hpc-devel-2.2-lp150.4.1.x86_64:
  package gnu-compilers-hpc-devel-1.3-lp150.4.1.noarch requires gcc-c++, but none of the providers can be installed
  package mvapich2-psm2_2_2-gnu-hpc-devel-2.2-lp150.4.1.x86_64 requires gnu-compilers-hpc-devel, but none of the providers can be installed
  package gcc-c++-7-lp150.1.27.x86_64 requires gcc7-c++, but none of the providers can be installed
  nothing provides libmpfr.so.4()(64bit) needed by gcc7-c++-7.3.0+r257042-lp150.1.3.x86_64

can't install mvapich2-psm2_2_2-gnu-hpc-devel-static-2.2-lp150.4.1.x86_64:
  package mvapich2-psm2_2_2-gnu-hpc-devel-2.2-lp150.4.1.x86_64 requires gnu-compilers-hpc-devel, but none of the providers can be installed
  package gnu-compilers-hpc-devel-1.3-lp150.4.1.noarch requires gcc-c++, but none of the providers can be installed
  package mvapich2-psm2_2_2-gnu-hpc-devel-static-2.2-lp150.4.1.x86_64 requires mvapich2-psm2_2_2-gnu-hpc-devel = 2.2, but none of the providers can be installed
  package gcc-c++-7-lp150.1.27.x86_64 requires gcc7-c++, but none of the providers can be installed
  nothing provides libmpfr.so.4()(64bit) needed by gcc7-c++-7.3.0+r257042-lp150.1.3.x86_64

can't install mvapich2-psm2_2_2-gnu-hpc-macros-devel-2.2-lp150.4.1.x86_64:
  package mvapich2-psm2_2_2-gnu-hpc-devel-2.2-lp150.4.1.x86_64 requires gnu-compilers-hpc-devel, but none of the providers can be installed
  package gnu-compilers-hpc-devel-1.3-lp150.4.1.noarch requires gcc-c++, but none of the providers can be installed
  package mvapich2-psm2_2_2-gnu-hpc-macros-devel-2.2-lp150.4.1.x86_64 requires mvapich2-psm2_2_2-gnu-hpc-devel = 2.2, but none of the providers can be installed
  package gcc-c++-7-lp150.1.27.x86_64 requires gcc7-c++, but none of the providers can be installed
  nothing provides libmpfr.so.4()(64bit) needed by gcc7-c++-7.3.0+r257042-lp150.1.3.x86_64

can't install mvapich2-psm_2_2-gnu-hpc-devel-2.2-lp150.4.1.x86_64:
  package gnu-compilers-hpc-devel-1.3-lp150.4.1.noarch requires gcc-c++, but none of the providers can be installed
  package mvapich2-psm_2_2-gnu-hpc-devel-2.2-lp150.4.1.x86_64 requires gnu-compilers-hpc-devel, but none of the providers can be installed
  package gcc-c++-7-lp150.1.27.x86_64 requires gcc7-c++, but none of the providers can be installed
  nothing provides libmpfr.so.4()(64bit) needed by gcc7-c++-7.3.0+r257042-lp150.1.3.x86_64

can't install mvapich2-psm_2_2-gnu-hpc-devel-static-2.2-lp150.4.1.x86_64:
  package mvapich2-psm_2_2-gnu-hpc-devel-2.2-lp150.4.1.x86_64 requires gnu-compilers-hpc-devel, but none of the providers can be installed
  package gnu-compilers-hpc-devel-1.3-lp150.4.1.noarch requires gcc-c++, but none of the providers can be installed
  package mvapich2-psm_2_2-gnu-hpc-devel-static-2.2-lp150.4.1.x86_64 requires mvapich2-psm_2_2-gnu-hpc-devel = 2.2, but none of the providers can be installed
  package gcc-c++-7-lp150.1.27.x86_64 requires gcc7-c++, but none of the providers can be installed
  nothing provides libmpfr.so.4()(64bit) needed by gcc7-c++-7.3.0+r257042-lp150.1.3.x86_64

can't install mvapich2-psm_2_2-gnu-hpc-macros-devel-2.2-lp150.4.1.x86_64:
  package mvapich2-psm_2_2-gnu-hpc-devel-2.2-lp150.4.1.x86_64 requires gnu-compilers-hpc-devel, but none of the providers can be installed
  package gnu-compilers-hpc-devel-1.3-lp150.4.1.noarch requires gcc-c++, but none of the providers can be installed
  package mvapich2-psm_2_2-gnu-hpc-macros-devel-2.2-lp150.4.1.x86_64 requires mvapich2-psm_2_2-gnu-hpc-devel = 2.2, but none of the providers can be installed
  package gcc-c++-7-lp150.1.27.x86_64 requires gcc7-c++, but none of the providers can be installed
  nothing provides libmpfr.so.4()(64bit) needed by gcc7-c++-7.3.0+r257042-lp150.1.3.x86_64

can't install mvapich2_2_2-gnu-hpc-devel-2.2-lp150.4.1.x86_64:
  package gnu-compilers-hpc-devel-1.3-lp150.4.1.noarch requires gcc-c++, but none of the providers can be installed
  package mvapich2_2_2-gnu-hpc-devel-2.2-lp150.4.1.x86_64 requires gnu-compilers-hpc-devel, but none of the providers can be installed
  package gcc-c++-7-lp150.1.27.x86_64 requires gcc7-c++, but none of the providers can be installed
  nothing provides libmpfr.so.4()(64bit) needed by gcc7-c++-7.3.0+r257042-lp150.1.3.x86_64

can't install mvapich2_2_2-gnu-hpc-devel-static-2.2-lp150.4.1.x86_64:
  package mvapich2_2_2-gnu-hpc-devel-2.2-lp150.4.1.x86_64 requires gnu-compilers-hpc-devel, but none of the providers can be installed
  package gnu-compilers-hpc-devel-1.3-lp150.4.1.noarch requires gcc-c++, but none of the providers can be installed
  package mvapich2_2_2-gnu-hpc-devel-static-2.2-lp150.4.1.x86_64 requires mvapich2_2_2-gnu-hpc-devel = 2.2, but none of the providers can be installed
  package gcc-c++-7-lp150.1.27.x86_64 requires gcc7-c++, but none of the providers can be installed
  nothing provides libmpfr.so.4()(64bit) needed by gcc7-c++-7.3.0+r257042-lp150.1.3.x86_64

can't install mvapich2_2_2-gnu-hpc-macros-devel-2.2-lp150.4.1.x86_64:
  package mvapich2_2_2-gnu-hpc-devel-2.2-lp150.4.1.x86_64 requires gnu-compilers-hpc-devel, but none of the providers can be installed
  package gnu-compilers-hpc-devel-1.3-lp150.4.1.noarch requires gcc-c++, but none of the providers can be installed
  package mvapich2_2_2-gnu-hpc-macros-devel-2.2-lp150.4.1.x86_64 requires mvapich2_2_2-gnu-hpc-devel = 2.2, but none of the providers can be installed
  package gcc-c++-7-lp150.1.27.x86_64 requires gcc7-c++, but none of the providers can be installed
  nothing provides libmpfr.so.4()(64bit) needed by gcc7-c++-7.3.0+r257042-lp150.1.3.x86_64

Login required, please login or signup in order to comment