Update for gd.openSUSE_Leap_15.0_Update security moderate

Security update for gd

This update for gd fixes the following issues:

Security issues fixed:

- CVE-2019-6977: Fixed a heap-based buffer overflow the GD Graphics Library used in the imagecolormatch function (bsc#1123361).
- CVE-2019-6978: Fixed a double free in the gdImage*Ptr() functions (bsc#1123522).

This update was imported from the SUSE:SLE-15:Update update project.

Fixed bugs
bnc#1123361
VUL-0: CVE-2019-6977: gd: A heap based buffer overflow is discovered in GD Graphics library
bnc#1123522
VUL-1: CVE-2019-6978: gd: The GD Graphics Library 2.2.5 has a double free in the gdImage*Ptr() functions in gd_gif_out.c, gd_jpeg.c, and gd_wbmp.c.
Selected Binaries
openSUSE Build Service is sponsored by