KDE Plasma 5.12 LTS

No description set
Name Changed
Comments for KDE:Frameworks5:LTS:5.12 1

Felipe Abrahao's avatar

ghostharley wrote about 1 year ago

Hi, I have being trying to test the latest LTS Qt 5.9.7 on my openSUSE Leap 15, but I'm getting unresolvable dependency issues with KDE Plasma packages (both Leap 15 "stock" KDE LTS 5.12.6 and latest KDE LTS 5.12.7 from https://download.opensuse.org/repositories/KDE:/Frameworks5:/LTS:/5.12/openSUSE_Leap_15.0/ are not working).

Almost every KDE Plasma package does not recognize libQt5 packages, e.g., libQt5Core 5.9.7, in this repository as the libQt5 dependency. When trying to install from the present repository with vendor change it displays tons of unresovable (unless uninstalling almost completely KDE Plasma 5.12) dependency issues. For example, for Kwin5.12.6 it displays the message: " kwin5-5.12.6-lp.2.3.1.x86_64 requires libQt5Core.so.5(Qt_5.9.4_PRIVATE_API)(64bit), but this requirement cannot be provided " and so on

On openSUSE Leap 42.3, I was able to use both latest KDE LTS and Qt LTS from the KDE repositories, and this dependency issue didn't happen when installing latest LTS Qt packages.

On Kubuntu, I'm currently using KDE 5.12.7 and Qt 5.9.7, and this dependency issue does not happen.

Best,