LogoopenSUSE Build Service > Projects
Sign Up | Log In

Next Ubuntu Release

This points to the next Ubuntu "main".

It includes also the packages from KUbuntu, XUbuntu and Edubuntu.

This project does not contain any packages

Comments for Ubuntu:Next (5)

dg0yt wrote over 1 year ago

Current project config asks for libmpfr4 and upstart-compat-sysv, but these do not exist any longer in bionic (18.04). So builds are not possible.

There is libmpfr6 (from source package mpfr4): https://packages.ubuntu.com/source/bionic/mpfr4

adrianSuSE wrote over 1 year ago

Thanks, adapted and removed the two further offenders... at least build package is building now again.

dg0yt wrote about 1 year ago

Ubuntu Next bash requires Preinstall: libtinfo6 for booting now.

[ 32s] /usr/bin/qemu-kvm -nodefaults -no-reboot -nographic -vga none -object rng-random,filename=/dev/random,id=rng0 -device virtio-rng-pci,rng=rng0 -runas qemu -cpu host -net none -kernel /boot/vmlinuz -initrd /boot/initrd -append root=/dev/sda rootfstype=ext3 rootflags=data=writeback,nobarrier,commit=150,noatime panic=1 quiet no-kvmclock nmi_watchdog=0 rw rd.driver.pre=binfmt_misc elevator=noop console=ttyS0 init=/.build/build -m 3000 -drive file=/var/cache/obs/worker/root_2/root,format=raw,if=none,id=disk,serial=0,cache=unsafe -device ide-hd,drive=disk -drive file=/var/cache/obs/worker/root_2/swap,format=raw,if=none,id=swap,serial=1,cache=unsafe -device ide-hd,drive=swap -serial stdio -chardev socket,id=monitor,server,nowait,path=/var/cache/obs/worker/root_2/root.qemu/monitor -mon chardev=monitor,mode=readline -smp 4 [ 36s] /bin/bash: error while loading shared libraries: libtinfo.so.6: cannot open shared object file: No such file or directory [ 36s] [ 3.575255] Kernel panic - not syncing: Attempted to kill init! exitcode=0x00007f00

dimesio wrote 3 months ago

Ubuntu_Next currently should be disco, but the Ubuntu_Next_universe repository seems to be pulling from an older version. Specifically, the version of libsdl2 in the actual Ubuntu disco universe repository is 2.0.9, but when I try to build a package that requires libsdl2, the OBS installs 2.0.8. If I specify libsdl2 >= 2.0.9 in the .dsc file, I get an unresolvable error.

dg0yt wrote 20 days ago

Ubuntu Next requires 'Preinstall: libpcre2-8-0' now:

[ 19s] Increasing log level from now on... [ 19s] mount: error while loading shared libraries: libpcre2-8.so.0: cannot open shared object file: No such file or directory [ 19s] mkdir: error while loading shared libraries: libpcre2-8.so.0: cannot open shared object file: No such file or directory [ 19s] mkdir: error while loading shared libraries: libpcre2-8.so.0: cannot open shared object file: No such file or directory [ 19s] mount: error while loading shared libraries: libpcre2-8.so.0: cannot open shared object file: No such file or directory [ 19s] mount: error while loading shared libraries: libpcre2-8.so.0: cannot open shared object file: No such file or directory [ 19s] mkswap: error while loading shared libraries: libpcre2-8.so.0: cannot open shared object file: No such file or directory [ 19s] swapon: error while loading shared libraries: libpcre2-8.so.0: cannot open shared object file: No such file or directory

Login required, please login or signup in order to comment