Stable Releases of Upstream github.com/containers packages

No description set
Name Changed
Comments for devel:kubic:libcontainers:stable 11

Trung Le's avatar

runlevel5 wrote 3 months ago

HI team

I would like to ask why there is no build for ppc64le on xUbuntu_20.04 and 20.10?

Thanks

Trung


Peter Hunt's avatar

haircommander wrote 3 months ago

I've attempted to enable it!


Lokesh Mandvekar's avatar

lsm5 wrote 3 months ago

@runlevel5 the ppc64le environment itself seems to not be setup correctly, so we just can't build any packages there. Last time I checked, there was some kernel issues and those were low on the priority list for the admins. So, there's not much we can do.


Michael Gray's avatar

lmgray wrote about 2 months ago

Sometime in the past few hours we've lost the ability to install docker-ce together with podman on centos-8. The problem seems to stem from an update to kubic containers-common-4 from 1-8 to 1-15. Previously installing podman and skopeo was pulling in containers-common-4:1-8.el8.13.6.noarch but as of a few hours ago that updated to containers-common-4:1-15.el8.14.1.noarch which seems to cause conflicts with docker-ce -- appreciate any recommendations to get podman and docker to peacefully coexist on centos-8 again...

[root@820280834a1c /]#  dnf config-manager --add-repo https://download.docker.com/linux/centos/docker-ce.repo
Failed to set locale, defaulting to C.UTF-8
Adding repo from: https://download.docker.com/linux/centos/docker-ce.repo
[root@820280834a1c /]# dnf install -y docker-ce docker-ce-cli
Failed to set locale, defaulting to C.UTF-8
Docker CE Stable - x86_64                                                                                                       50 kB/s |  12 kB     00:00
Error:
 Problem: package docker-ce-3:20.10.6-3.el8.x86_64 requires containerd.io >= 1.4.1, but none of the providers can be installed
  - package containerd.io-1.4.3-3.1.el8.x86_64 conflicts with runc provided by runc-1.0.0-70.rc92.module_el8.3.0+699+d61d9c41.x86_64
  - package containerd.io-1.4.3-3.1.el8.x86_64 obsoletes runc provided by runc-1.0.0-70.rc92.module_el8.3.0+699+d61d9c41.x86_64
  - package containerd.io-1.4.3-3.2.el8.x86_64 conflicts with runc provided by runc-1.0.0-70.rc92.module_el8.3.0+699+d61d9c41.x86_64
  - package containerd.io-1.4.3-3.2.el8.x86_64 obsoletes runc provided by runc-1.0.0-70.rc92.module_el8.3.0+699+d61d9c41.x86_64
  - package containerd.io-1.4.4-3.1.el8.x86_64 conflicts with runc provided by runc-1.0.0-70.rc92.module_el8.3.0+699+d61d9c41.x86_64
  - package containerd.io-1.4.4-3.1.el8.x86_64 obsoletes runc provided by runc-1.0.0-70.rc92.module_el8.3.0+699+d61d9c41.x86_64
  - problem with installed package podman-2.2.1-7.module_el8.3.0+699+d61d9c41.x86_64
  - package podman-2.2.1-7.module_el8.3.0+699+d61d9c41.x86_64 requires runc >= 1.0.0-57, but none of the providers can be installed
  - cannot install the best candidate for the job
  - package runc-1.0.0-64.rc10.module_el8.3.0+479+69e2ae26.x86_64 is filtered out by modular filtering
(try to add '--allowerasing' to command line to replace conflicting packages or '--skip-broken' to skip uninstallable packages or '--nobest' to use not only best candidate packages)

Lokesh Mandvekar's avatar

lsm5 wrote about 2 months ago

I see packages are still being pulled from the container-tools module. Can you confirm you have disabled container-tools module?

sudo dnf -y module disable container-tools

See the centos section in https://podman.io/getting-started/installation

Until that's done, there's probably not much I can help with.


Michael Gray's avatar

lmgray wrote about 2 months ago

Within the past hour or so...

5c5
<   containers-common-4:1-15.el8.14.1.noarch
---
>   containers-common-4:1-16.el8.15.1.noarch

And things are better now -- thanks!


Roland Sommer's avatar

rsommer wrote about 1 month ago

Hi,

I just discovered that podman builds for Debian_10 have been disabled, but I could not find any information about the reasons. Any hints about that here?

Thanks, Roland


Richard Brown's avatar

RBrownSUSE wrote about 1 month ago

I don't see any evidence that builds for Debian_10 have been disabled..how/where did you discover this?


Roland Sommer's avatar

rsommer wrote about 1 month ago

Sorry, I wasn't specific enough (edited already), I was refering to the podman builds. These are marked as "disabled" and there are indeed no builds for podman 3.1 in the repository.


Valentin Rothberg's avatar

vrothberg wrote about 1 month ago

Older distros are not receiving packages anymore (see https://podman.io/blogs/2021/03/02/podman-support-for-older-distros.html).

The support matrix grew too big to keep up with all the packaging work. Especially older distros are challenging (e.g., old kernels, old libraries, etc.).


Roland Sommer's avatar

rsommer wrote about 1 month ago

Thanks for clarification - I totally missed that blog post.

openSUSE Build Service is sponsored by