File QLandkarte.spec of Package QLandkarte
#
# spec file for package QLandkarte
#
# Copyright (c) 2008 SUSE LINUX Products GmbH, Nuernberg, Germany.
#
# All modifications and additions to the file contributed by third parties
# remain the property of their copyright owners, unless otherwise agreed
# upon. The license for this file, and modifications and additions to the
# file, is the same license as for the pristine package itself (unless the
# license for the pristine package is not an Open Source License, in which
# case the license is the MIT License). An "Open Source License" is a
# license that conforms to the Open Source Definition (Version 1.9)
# published by the Open Source Initiative.
# Please submit bugfixes or comments via http://bugs.opensuse.org/
#
# norootforbuild
Name: QLandkarte
Summary: Garmin GPS Map, Route, Waypoint and Tracking Tool
Version: final
Release: 1
Group: Productivity/Other
License: GPL v2 or later
BuildRoot: %{_tmppath}/%{name}-%{version}-build
Url: http://qlandkarte.sourceforge.net
Source: %{name}_%{version}.tar.bz2
Patch0: autoconf_compileflags.patch
Patch1: adapt_desktopfile.patch
BuildRequires: libproj-devel
BuildRequires: libqt4-devel
BuildRequires: libusb-devel
BuildRequires: update-desktop-files
BuildRequires: gcc-c++
BuildRequires: autoconf
BuildRequires: automake
ExclusiveArch: %ix86 x86_64
%description
Garmin's MapSource software is hardly the only reason for me to boot
into Windows and it does not look like Garmin ever wants to address
Linux users by writing a portable piece of software. So I started to
help myself. I found several tools like GPSBabel or sendmap to handle
data for my GPS receiver but no tool to visualize and manage this data
in a decent way. On my quest I found a specification of the used IMG
format for maps at Sourceforge. After some reading and toying around I
considered this specification good enough to start a GUI project to
visualize such files. QLandkarte is the result of this effort.
Including additional patches by fseidel@suse.de which are upstream and
tested but not yet released elsewhere.
%prep
%setup -n %{name}_%{version}
%patch0 -p1
%patch1 -p1
%build
autoreconf -fi
echo "DEFINES += QL_LIBDIR=%{_libdir}/qlandkarte" > common
export CFLAGS="$RPM_OPT_FLAGS"
export CPPFLAGS="$RPM_OPT_FLAGS"
export CXXFLAGS="$RPM_OPT_FLAGS"
export LDFLAGS="$LDFLAGS $RPM_OPT_FLAGS"
%{configure} --prefix=%{_prefix} --libdir=%{_libdir}
%{__make} #CXXFLAGS="-pipe -g -D_REENTRANT -Wall -W -DQL_LIBDIR=/usr/lib/qlandkarte -DQT_NO_DEBUG_OUTPUToff -DQT_XML_LIB -DQT_GUI_LIB -DQT_NETWORK_LIB -DQT_CORE_LIB -DQT_SHARED -fPIC $RPM_OPT_FLAGS"
%install
mkdir -p %{buildroot}%{_bindir}
mkdir -p %{buildroot}%{_libdir}/qlandkarte
mkdir -p %{buildroot}/%{_prefix}/share/pixmaps
#cp bin/QLandkarte %{buildroot}%{_bindir}/
#cp -av bin/plugins/* %{buildroot}%{_libdir}/qlandkarte/
cp -v src/icons/iconScreenshot16x16.png %{buildroot}%{_prefix}/share/pixmaps/qlandkarte.png
export DESTDIR=%{buildroot}
export INSTALL_ROOT=$DESTDIR
%{makeinstall}
rm -frv $DESTDIR/usr/share/menu
%suse_update_desktop_file -i qlandkarte Utility Archiving
# make sure file is really gzipped
gzip %{buildroot}%{_prefix}/share/man/qlandkarte.1
%clean
rm -rf %{buildroot}
%files
%defattr(-,root,root)
%{_bindir}/qlandkarte
%{_libdir}/qlandkarte
%doc %{_prefix}/share/man/qlandkarte.1.gz
%{_prefix}/share/applications/qlandkarte.desktop
%{_prefix}/share/pixmaps/qlandkarte.png
%doc copying INSTALL
%changelog