File monav.spec of Package monav
#
# spec file for package monav
#
# Copyright (c) 2013 SUSE LINUX Products GmbH, Nuernberg, Germany.
#
# All modifications and additions to the file contributed by third parties
# remain the property of their copyright owners, unless otherwise agreed
# upon. The license for this file, and modifications and additions to the
# file, is the same license as for the pristine package itself (unless the
# license for the pristine package is not an Open Source License, in which
# case the license is the MIT License). An "Open Source License" is a
# license that conforms to the Open Source Definition (Version 1.9)
# published by the Open Source Initiative.
# Please submit bugfixes or comments via http://bugs.opensuse.org/
#
Name: monav
Version: 0.3
Release: 0
Url: http://code.google.com/p/monav
BuildRoot: %{_tmppath}/%{name}-%{version}-build
BuildRequires: libbz2-devel
BuildRequires: libproj-devel
BuildRequires: libqt4-devel >= 4.7
BuildRequires: libxml2-devel
BuildRequires: mapnik-devel
BuildRequires: protobuf-devel
BuildRequires: qt-mobility-devel >= 1.1
BuildRequires: hdf5-devel
Source: http://monav.googlecode.com/files/%name-%version.tar.gz
Summary: OpenStreetMap routing
License: GPL-3.0+
Group: Productivity/Other
Patch: 05-drop_marchnative.patch
Patch2: 07-port_to_mapnik2.patch
%description
MoNav is a Desktop / Mobile application that offers state-of-the-art fast
and exact routing with OpenStreetMap Data.
%prep
%setup -q
%patch -p1
%patch2 -p1
%build
export CFLAGS="$RPM_BUILD_OPTS -g"
qmake QMAKE_CXXFLAGS_RELEASE+="$CFLAGS" monavclient.pro && make %{?_smp_mflags}
make clean
qmake CONFIG+=nogui QMAKE_CXXFLAGS_RELEASE+="$CFLAGS" monavpreprocessor.pro && make %{?_smp_mflags}
make clean
qmake QMAKE_CXXFLAGS_RELEASE+="$CFLAGS" monavpreprocessor-gui.pro && make %{?_smp_mflags}
make clean
qmake CONFIG+=nogui QMAKE_CXXFLAGS_RELEASE+="$CFLAGS" monavroutingdaemon.pro && make %{?_smp_mflags}
make clean
qmake CONFIG+=nogui QMAKE_CXXFLAGS_RELEASE+="$CFLAGS" tools/monav-packager/monav-packager.pro && make %{?_smp_mflags}
%install
install -d -m 0755 $RPM_BUILD_ROOT/usr/bin
install -m 0755 bin/monav* $RPM_BUILD_ROOT/usr/bin/
install -m 0755 monav-packager $RPM_BUILD_ROOT/usr/bin/
%clean
rm -rf "$RPM_BUILD_ROOT"
%files
%defattr(-,root,root,-)
/usr/bin/*
%changelog