File gammaray.spec of Package gammaray

#
# spec file for package gammaray
#
# Copyright (c) 2016 SUSE LINUX GmbH, Nuernberg, Germany.
#
# All modifications and additions to the file contributed by third parties
# remain the property of their copyright owners, unless otherwise agreed
# upon. The license for this file, and modifications and additions to the
# file, is the same license as for the pristine package itself (unless the
# license for the pristine package is not an Open Source License, in which
# case the license is the MIT License). An "Open Source License" is a
# license that conforms to the Open Source Definition (Version 1.9)
# published by the Open Source Initiative.

# Please submit bugfixes or comments via http://bugs.opensuse.org/
#


%define tarname GammaRay
Name:           gammaray
Version:        2.6.0
Release:        0
Summary:        Introspection/Debugging Tool for Qt Applications
License:        GPL-2.0+
Group:          Development/Tools/Debuggers
Url:            http://www.kdab.com/gammaray
Source:         https://github.com/KDAB/GammaRay/releases/download/v%{version}/%{name}-%{version}.tar.gz
BuildRequires:  cmake >= 2.8.11
BuildRequires:  fdupes
BuildRequires:  kcoreaddons-devel
# include this so the icon folders don't need to be owned by the package
BuildRequires:  doxygen
BuildRequires:  graphviz-devel
BuildRequires:  hicolor-icon-theme
BuildRequires:  libQt5Core-private-headers-devel >= 5.2.0
BuildRequires:  libQt5Gui-private-headers-devel >= 5.2.0
BuildRequires:  libQt5Network-private-headers-devel >= 5.2.0
BuildRequires:  libqt5-qt3d-devel >= 5.2.0
BuildRequires:  libqt5-qtbase-doc >= 5.2.0
BuildRequires:  libqt5-qtdeclarative-private-headers-devel >= 5.2.0
BuildRequires:  libqt5-qtdoc >= 5.2.0
BuildRequires:  libqt5-qtwayland-devel >= 5.2.0
BuildRequires:  libxml2-devel
BuildRequires:  python-devel
BuildRequires:  update-desktop-files
BuildRequires:  vtk-devel
BuildRequires:  vtk-java
BuildRequires:  vtk-qt
BuildRequires:  vtk-tcl
BuildRequires:  wayland-devel
BuildRequires:  cmake(Qt5Bluetooth) >= 5.2.0
BuildRequires:  cmake(Qt5Concurrent) >= 5.2.0
BuildRequires:  cmake(Qt5Core) >= 5.2.0
BuildRequires:  cmake(Qt5Designer) >= 5.2.0
BuildRequires:  cmake(Qt5Gui) >= 5.2.0
BuildRequires:  cmake(Qt5Network) >= 5.2.0
BuildRequires:  cmake(Qt5Positioning) >= 5.2.0
BuildRequires:  cmake(Qt5PrintSupport) >= 5.2.0
BuildRequires:  cmake(Qt5Qml) >= 5.2.0
BuildRequires:  cmake(Qt5Quick) >= 5.2.0
BuildRequires:  cmake(Qt5Script) >= 5.2.0
BuildRequires:  cmake(Qt5ScriptTools) >= 5.2.0
BuildRequires:  cmake(Qt5Svg) >= 5.2.0
BuildRequires:  cmake(Qt5Test) >= 5.2.0
BuildRequires:  cmake(Qt5WebKitWidgets) >= 5.2.0
BuildRequires:  cmake(Qt5Widgets) >= 5.2.0
BuildRoot:      %{_tmppath}/%{name}-%{version}-build

%description
Gamma Ray is a comprehensive collection of high level introspection 
and debugging utilities specifically tailored for the various 
frameworks in Qt.

%package devel
Summary:        Introspection/Debugging Tool for Qt Applications
Group:          Development/Libraries/C and C++
Requires:       %{name} = %{version}

%description devel
Gamma Ray is a comprehensive collection of high level introspection 
and debugging utilities specifically tailored for the various 
frameworks in Qt. Development files.

%prep
%setup -q -n %{name}-%{version}

%build
%if "%{_lib}" == "lib64"
LIBSUFFIX="-DLIB_SUFFIX=64"
%else
LIBSUFFIX=""
%endif
cmake . -DCMAKE_INSTALL_PREFIX=%{_prefix} \
        -DCMAKE_SKIP_INSTALL_RPATH=ON \
        -DCMAKE_VERBOSE_MAKEFILE=ON \
        -DECM_MKSPECS_INSTALL_DIR=%{_libdir}/qt5/mkspecs/modules \
        -DQCH_INSTALL_DIR=%{_datadir}/gammaray/ \
        $LIBSUFFIX
make VERBOSE=1 %{?_smp_mflags}

%install
make DESTDIR=%{buildroot} install

install -d -m 755 %{buildroot}%{_docdir}/%{name}
mv %{buildroot}%{_datadir}/doc/%{name} %{buildroot}%{_docdir}
%suse_update_desktop_file GammaRay Development Qt Debugger
%fdupes %{buildroot}

%post
/sbin/ldconfig

%postun
/sbin/ldconfig

%files
%defattr(-,root,root)
%doc CHANGES ReadMe.txt LICENSE.*
%dir %{_datadir}/icons/hicolor/512x512/
%dir %{_datadir}/icons/hicolor/512x512/apps/
%{_bindir}/gammaray
%{_datadir}/applications/GammaRay.desktop
%{_datadir}/icons/hicolor/*/apps/GammaRay.png
%{_docdir}/%{name}/
%{_libdir}/gammaray/
%{_libdir}/libgammaray_*-qt5*.so.*
%{_libdir}/libgammaray_client.so.*
%{_libdir}/libgammaray_launcher.so.*
%{_mandir}/man1/gammaray.*
%if 0%{?suse_version} <= 1320
%dir %{_datadir}/appdata
%endif
%{_datadir}/appdata/GammaRay.appdata.xml
%{_datadir}/gammaray

%files devel
%defattr(-,root,root)
%{_libdir}/libgammaray_*-qt5*.so
%{_libdir}/libgammaray_client.so
%{_libdir}/libgammaray_launcher.so
%{_libdir}/cmake/GammaRay/
%{_includedir}/%{name}
%{_libdir}/qt5/mkspecs/modules/qt_GammaRay*.pri

%changelog
openSUSE Build Service is sponsored by