File ghc-strict.changes of Package ghc-strict

-------------------------------------------------------------------
Wed Oct  4 15:55:15 UTC 2023 - Peter Simons <psimons@suse.com>

- Update strict to version 0.5 revision 1.
  Upstream has revised the Cabal build instructions on Hackage.

-------------------------------------------------------------------
Tue Jun 14 20:10:31 UTC 2023 - Peter Simons <psimons@suse.com>

- Update strict to version 0.5.
  # 0.5

  - Depend on `bifunctor-classes-compat` instead of `bifunctors`
    See changelog note in `bifunctors-5.6`: https://hackage.haskell.org/package/bifunctors-5.6/changelog
    This is breaking change, but affects only GHC-8.0 and older users.

-------------------------------------------------------------------
Thu Mar 30 17:08:27 UTC 2023 - Peter Simons <psimons@suse.com>

- Updated spec file to conform with ghc-rpm-macros-2.5.2.

-------------------------------------------------------------------
Sat Jan  1 00:53:29 UTC 2022 - Peter Simons <psimons@suse.com>

- Update strict to version 0.4.0.1 revision 4.
  Upstream has revised the Cabal build instructions on Hackage.

-------------------------------------------------------------------
Tue Nov 16 19:50:41 UTC 2021 - psimons@suse.com

- Update strict to version 0.4.0.1 revision 3.
  Upstream has revised the Cabal build instructions on Hackage.

-------------------------------------------------------------------
Mon Nov  1 08:24:04 UTC 2021 - psimons@suse.com

- Update strict to version 0.4.0.1 revision 2.
  Upstream has revised the Cabal build instructions on Hackage.

-------------------------------------------------------------------
Wed Jul 28 07:42:33 UTC 2021 - psimons@suse.com

- Update strict to version 0.4.0.1 revision 1.
  Upstream has revised the Cabal build instructions on Hackage.

-------------------------------------------------------------------
Thu Dec 17 12:20:00 UTC 2020 - Ondřej Súkup <mimi.vx@gmail.com>
 
- disable %{ix86} build
 
-------------------------------------------------------------------
Sun Dec  6 19:00:17 UTC 2020 - psimons@suse.com

- Update strict to version 0.4.0.1.
  # 0.4.0.1

  - Allow `bytestring-0.11`
  - Remove duplicate `semigroups` dependency

-------------------------------------------------------------------
Tue Aug 18 10:46:06 UTC 2020 - Peter Simons <psimons@suse.com>

- Replace %setup -q with the more modern %autosetup macro.

-------------------------------------------------------------------
Tue Aug 11 09:28:18 UTC 2020 - psimons@suse.com

- Add strict at version 0.4.

openSUSE Build Service is sponsored by