File pyqpcr.spec of Package pyqpcr
#
# spec file for package pyqpcr
#
# Copyright (c) 2012 SUSE LINUX Products GmbH, Nuernberg, Germany.
#
# All modifications and additions to the file contributed by third parties
# remain the property of their copyright owners, unless otherwise agreed
# upon. The license for this file, and modifications and additions to the
# file, is the same license as for the pristine package itself (unless the
# license for the pristine package is not an Open Source License, in which
# case the license is the MIT License). An "Open Source License" is a
# license that conforms to the Open Source Definition (Version 1.9)
# published by the Open Source Initiative.
#
# Please submit bugfixes or comments via http://bugs.opensuse.org/
#
Name: pyqpcr
%define modname pyQPCR
Version: 0.9
Release: 0
Url: http://pyqpcr.sourceforge.net/
Summary: GUI to perform qPCR analysis
License: GPL-3.0
Group: Productivity/Scientific/Other
Source: %{name}-%{version}.tar.gz
BuildRoot: %{_tmppath}/%{name}-%{version}-build
BuildRequires: python-devel
BuildRequires: python-numpy-devel
BuildRequires: python-matplotlib
BuildRequires: python-scipy-devel
BuildRequires: update-desktop-files
%if 0%{?suse_version} <= 1110
BuildRequires: python-qt4
%{!?python_sitelib: %global python_sitelib %(python -c "from distutils.sysconfig import get_python_lib; print(get_python_lib())")}
%else
BuildRequires: python-qt4-devel
BuildArch: noarch
%{py_requires}
%endif
%description
pyQPCR is a GUI application written in python that deals with quantitative PCR (QPCR) raw data. Using quantification cycle values extracted from QPCR instruments, it uses a proven and universally applicable model to give finalized quantification results.
%prep
%setup -q
%build
CFLAGS="%{optflags}" python setup.py build
%install
python setup.py install --prefix=%{_prefix} --root=%{buildroot}
chmod +x %{buildroot}%{python_sitelib}/%{modname}/mainWindow.py
%if 0%{sles_version} <= 11
%suse_update_desktop_file %{buildroot}%{_datadir}/applications/pyQPCR.desktop
%endif
%files
%defattr(-,root,root,-)
%{_bindir}/qpcr
%{python_sitelib}/%{modname}/
%{python_sitelib}/%{modname}-%{version}-py%{py_ver}.egg-info
%if 0%{sles_version} <=11
%exclude %{_datadir}/applications
%exclude %{_datadir}/icons
%endif
%changelog