File mingw64-liboauth.spec of Package mingw64-liboauth
#
# spec file for package mingw64-liboauth
#
# Copyright (c) 2014 SUSE LINUX Products GmbH, Nuernberg, Germany.
#
# All modifications and additions to the file contributed by third parties
# remain the property of their copyright owners, unless otherwise agreed
# upon. The license for this file, and modifications and additions to the
# file, is the same license as for the pristine package itself (unless the
# license for the pristine package is not an Open Source License, in which
# case the license is the MIT License). An "Open Source License" is a
# license that conforms to the Open Source Definition (Version 1.9)
# published by the Open Source Initiative.
# Please submit bugfixes or comments via http://bugs.opensuse.org/
#
Name: mingw64-liboauth
Version: 1.0.1
Release: 0
Summary: MinGW Windows port of OAuth library
License: MIT
Group: Development/Libraries/C and C++
Url: http://liboauth.sourceforge.net/
Source0: liboauth-%{version}.tar.gz
Patch0: liboauth-0.9.5-noundefined.patch
#!BuildIgnore: post-build-checks
BuildRequires: autoconf
BuildRequires: automake
BuildRequires: libtool
BuildRequires: mingw64-cross-binutils
BuildRequires: mingw64-cross-gcc
BuildRequires: mingw64-cross-gcc-c++
BuildRequires: mingw64-cross-pkg-config
BuildRequires: mingw64-filesystem >= 35
BuildRequires: mingw64-libcurl-devel
BuildRequires: mingw64-mozilla-nss-devel
%_mingw64_package_header_debug
BuildArch: noarch
%description
liboauth is a collection of c functions implementing the http://oauth.net API.
%package -n mingw64-liboauth0
Summary: MinGW Windows port of OAuth library
Group: System/Libraries
Obsoletes: %{name}
Provides: %{name}
%description -n mingw64-liboauth0
liboauth is a collection of c functions implementing the http://oauth.net API.
liboauth provides functions to escape and encode stings according to
OAuth specifications and offers high-level functionality built on top to sign
requests or verify signatures using either NSS or OpenSSL for calculating
the hash/signatures.
%package devel
Summary: MinGW Windows port of liboauth - Development and Include Files
Group: Development/Libraries/C and C++
%description devel
liboauth is a collection of c functions implementing the http://oauth.net API.
liboauth provides functions to escape and encode stings according to
OAuth specifications and offers high-level functionality built on top to sign
requests or verify signatures using either NSS or OpenSSL for calculating
the hash/signatures.
This archive contains the header files for liboauth development.
%_mingw64_debug_package
%prep
%setup -q -n liboauth-%{version}
%patch -P 0 -p1 -b .noundefined
%build
echo "lt_cv_deplibs_check_method='pass_all'" >>%{_mingw64_cache}
libtoolize --force --copy --install
autoreconf -f -i
PATH="%{_mingw64_bindir}:$PATH" \
MINGW64_CFLAGS="%_mingw64_cflags -I%{_mingw64_includedir}/nspr4"
%{_mingw64_configure} --disable-static --enable-shared --enable-libcurl --disable-curl --enable-nss
%{_mingw64_make} %{?_smp_mflags} || %{_mingw64_make}
%install
%{_mingw64_make} install DESTDIR=%{buildroot}
%files -n mingw64-liboauth0
%defattr(-,root,root)
%{_mingw64_bindir}/liboauth-0.dll
%files devel
%defattr(-,root,root)
%{_mingw64_includedir}/oauth.h
%{_mingw64_libdir}/pkgconfig/oauth.pc
%{_mingw64_libdir}/liboauth.dll.a
%{_mingw64_mandir}/man*/*
%changelog