LogoopenSUSE Build Service > Request 150650
Sign Up | Log In

Request 150650 (accepted)

Fix undefined symbol errors caused by mixing the v8 headers bundled with
nodejs with the system v8 libraries.  Changes taken from/inspired by Fedora,
except my install.py patch, which I wrote myself.

I did not integrate, but it may be worth considering, the v8 ABI deps
Fedora uses.  At the very least we need to make sure nodejs gets rebuilt
after a libv8 version bump (e.g. 3.15.x to 3.16.x, not necessary for
3.16.x to 3.16.y).

Submit package home:adaugherity...anguages:nodejs / nodejs (revision 2) to package devel:languages:nodejs / nodejs

[-] [+] Changed nodejs.changes
[-] [+] Changed nodejs.spec ^
[-] [+] Added node-gyp-addon-gypi.patch ^
[-] [+] Added nodejs-no-v8-headers.patch ^
Deleted node-v0.8.12.tar.gz ^

There's nothing to be done right now

Request History

Andrew Daugherity adaugherity created request over 3 years ago
Fix undefined symbol errors caused by mixing the v8 headers bundled with
nodejs with the system v8 libraries.  Changes taken from/inspired by Fedora,
except my install.py patch, which I wrote myself.

I did not integrate, but it may be worth considering, the v8 ABI deps
Fedora uses.  At the very least we need to make sure nodejs gets rebuilt
after a libv8 version bump (e.g. 3.15.x to 3.16.x, not necessary for
3.16.x to 3.16.y).
Jordi Massaguer jordimassaguerpla Request got accepted over 3 years ago
this patch looks good to me. Thanks!

Comments for request 150650 (0)