LogoopenSUSE Build Service > Request 157853
Sign Up | Log In

Request 157853 (accepted)

- Set ExclusiveArch to x86 and ARM
  nodejs depends on v8 which is available only for those arches atm

Submit package home:k0da:ppc / nodejs to package devel:languages:nodejs / nodejs

[-] [+] Changed nodejs.changes
[-] [+] Changed nodejs.spec ^

There's nothing to be done right now

Request History

Dinar Valeev k0da created request about 3 years ago
- Set ExclusiveArch to x86 and ARM
  nodejs depends on v8 which is available only for those arches atm
Jordi Massaguer jordimassaguerpla Request got declined about 3 years ago
I do not think that is good idea. If v8 were available, someone would need to remember to remove this line. If we stayed as we are, the build service would build it. AFAIK, you will get a "unresolvable" error if you try to build nodejs for another arch.
Dinar Valeev k0da Request got reviewed about 3 years ago
It doesn't make sense to try to build nodejs on the platforms without v8.
Jordi Massaguer jordimassaguerpla Request got declined about 3 years ago
I am against having the "ExlusiveArch" in the spec file. Having the "BuildRequires:  v8-devel >= 3.7" already prevents building it on the archs where v8 is not available. I don't think nodejs is exclusive for the archs you mention. What it is exclusive is v8, not nodejs. Unless that were the case, I am not accepting this request.
Dinar Valeev k0da Request got reviewed about 3 years ago
Reopen. Due to nodejs can't live without v8 for sure.
Marcus Rückert darix Request got accepted about 3 years ago
ok

Comments for request 157853 (0)