LogoopenSUSE Build Service > Request 246783
Sign Up | Log In

Request 246783 (superseded)

- Fix BuildRequires and runtime Requires with rubygem-multipart-post

Submit package home:mjura:...:extensions / rubygem-faraday to package devel:langu...:extensions / rubygem-faraday

home:mjura:branches:devel:languages:ruby:extensions

There's nothing to be done right now

Request History

Michal Jura mjura created request over 1 year ago
- Fix BuildRequires and runtime Requires with rubygem-multipart-post
Michal Jura mjura Request got superseded by request 247023 over 1 year ago
superseded by 247023

Comments for request 246783 (2)

Michal Jura mjura wrote over 1 year ago

Hi,

Is it right to write this requirements in following way +BuildRequires: rubygem-multipart-post < 3 +BuildRequires: rubygem-multipart-post >= 1.2 +Requires: rubygem-multipart-post < 3 +Requires: rubygem-multipart-post >= 1.2

Klaus Kämpf kwk wrote over 1 year ago

If you want to express 'rubygem-multipart-post between 1.2 and 3', that's not possible in rpm (yet).

Your current .spec works by chance but RPM might as well install, lets say, rubygem-multipart-post == 3.0 (fulfills >= 1.2) and rubygem-multipart-post == 1.0 (fulfills < 3) in parallel.