- Fix BuildRequires and runtime Requires with rubygem-multipart-post
package home:mjura:...:extensions / rubygem-faraday
package devel:langu...:extensions / rubygem-faraday
There's nothing to be done right now
superseded by 247023
Is it right to write this requirements in following way
+BuildRequires: rubygem-multipart-post < 3
+BuildRequires: rubygem-multipart-post >= 1.2
+Requires: rubygem-multipart-post < 3
+Requires: rubygem-multipart-post >= 1.2
If you want to express 'rubygem-multipart-post between 1.2 and 3', that's not possible in rpm (yet).
Your current .spec works by chance but RPM might as well install, lets say, rubygem-multipart-post == 3.0 (fulfills >= 1.2) and rubygem-multipart-post == 1.0 (fulfills < 3) in parallel.
Open Build Service (OBS) is an openSUSE project.