Flexible Context-aware Input Tool with eXtension

In 12.2, openSUSE will bring you two excellent and modern Input Method Frameworks (IMF), one of them is fcitx, a Flexible Context-aware Input Tool with eXtension. It is default input method for locale as ko, zh_CN and zh_SG.

Fcitx supports pinyin and table input methods. thus it supports many African and Asian locales. (you can find many fcitx-table-* package with details about which locale it applies in YaST) Besides the wide coverage, fcitx is also the leader of creative features in IMF field. It by now supports Import of User Dictionaries (like create your own input tables), GNOME 3/KDE 4 native configuration module (through a GNOME extension kimpanel and a kcm-module kcm-fcitx, which is the first IMF using KCM technology!), KDE 4 integration with a plasmoid named KIMpanel or a 3rd-party application named KIMToy, English Keyboard with libpresage predition support, best 3rd-party IMs' integration like Sunpinyin/libpinyin/Googlepinyin/RIME with no-pain trans-inputing between CJK. Even can fetch words from Internet servers to power your inputs! And it ships the capability of using Skins (branding-openSUSE is good, but you still can get more from kde-look.org. There's a special section for Fcitx!)

Refresh
Refresh
Source Files (show merged sources derived from linked package)
Filename Size Changed Actions
baselibs.conf 0000001228 1.2 KB about 4 years
fcitx-4.2.9.6_dict.tar.xz 0008738408 8.33 MB over 1 year
fcitx-README.suse 0000002963 2.89 KB almost 7 years
fcitx-autostart-check-INPUT_METHOD.patch 0000000286 286 Bytes almost 4 years
fcitx-cmake-3.1.patch 0000001052 1.03 KB over 1 year
fcitx.changes 0000031689 30.9 KB over 1 year
fcitx.spec 0000017591 17.2 KB over 1 year
macros.fcitx 0000000617 617 Bytes about 6 years
openSUSE-themes.tar.gz 0001089321 1.04 MB almost 5 years
xim.d-fcitx 0000000500 500 Bytes almost 4 years
xim.fcitx.suse.template 0000000841 841 Bytes over 5 years
Comments for fcitx 3

Repo Checker

repo-checker wrote over 1 year ago

The version of this package in openSUSE:Leap:15.0 has installation issues and may not be installable:

can't install fcitx-devel-4.2.9.5-lp150.1.7.x86_64:
  package libqt4-devel-4.8.7-lp150.6.5.x86_64 requires c++_compiler, but none of the providers can be installed
  package fcitx-devel-4.2.9.5-lp150.1.7.x86_64 requires pkgconfig(QtCore), but none of the providers can be installed
  package fcitx-devel-4.2.9.5-lp150.1.7.x86_64 requires pkgconfig(QtGui), but none of the providers can be installed
  package fcitx-devel-4.2.9.5-lp150.1.7.x86_64 requires pkgconfig(QtDBus), but none of the providers can be installed
  package gcc-c++-7-lp150.1.27.x86_64 requires gcc7-c++, but none of the providers can be installed
  nothing provides libmpfr.so.4()(64bit) needed by gcc7-c++-7.3.0+r257042-lp150.1.3.x86_64

Xu Zhao

nuklly wrote over 1 year ago

When can we upgrade fcitx to 4.2.9.6? Also, we should remove the hard dependency between fcitx and fcitx-qt4/fcitx-gtk2.