Edit Package virglrenderer

Virgl Rendering library


The virgil3d rendering library is a library used by
qemu to implement 3D GPU support for the virtio GPU.

Source Files (show merged sources derived from linked package)
Filename Size Changed
virglrenderer-CVE-2022-0135.patch 0000002641 2.58 KB 10 months
virglrenderer-CVE-2022-0175.patch 0000003166 3.09 KB 11 months
virglrenderer-virglrenderer-0.9.1.tar.gz 0002945799 2.81 MB over 1 year
virglrenderer.changes 0000008643 8.44 KB 10 months
virglrenderer.spec 0000003156 3.08 KB 10 months
Comments 6

Episteme PROMENEUR's avatar

promeneur wrote 11 months ago


Any hope to get a version for 15.3 ?


Dario Faggioli's avatar

dfaggioli wrote 11 months ago

I branched [1] and tried to enable the build. The problem seems to be a not enough updated libepoxy: "unresolvable: nothing provides pkgconfig(epoxy) >= 1.5.4, (got version 1.4.3 provided by libepoxy-devel)"

In fact, in the specfile, we have: BuildRequires: pkgconfig(epoxy) >= 1.5.4

I'm not sure what the best way forward would be, i.e., whether to try to build with the libepoxy we have there (perhaps using an older version of this virglrenderer itself) or to try to update libepoxy in 15.3.


[1] https://build.opensuse.org/package/show/home:dfaggioli:devel:Virtualization/virglrenderer

Episteme PROMENEUR's avatar

promeneur wrote 10 months ago



Why not adding the needed packages in a 15.3 "virtualization" repo ?

There is a similar case for pipewire 3.45 which needs a recent version of meson.

geekositalia added the good meson package. Then we get a complete pipewire (with wireplumber) for 15.3

see https://build.opensuse.org/package/show/home%3Ageekositalia%3Apipewire/pipewire

Olaf Hering's avatar

olh wrote 11 months ago

Leap 15.3 already includes this package, it is inherited from SLE. In case you are asking for something newer than 0.6.0, update to a base system which does have the required libepoxy, like Leap 15.4 or Tumbleweed.

James Fehlig's avatar

jfehlig wrote 11 months ago

15.4 contains a newer libepoxy-1.5.9, but still inherits the old 0.6.0 virglrenderer. We'll need to explicitly update virglrenderer if we want an newer one in 15.4.

Dario Faggioli's avatar

dfaggioli wrote 11 months ago

Yep, I think we should update the version in 15.4 to the one we have here. In fact, I think we can link the 15.4 version to this package, and then submit it to GA

openSUSE Build Service is sponsored by