Edit Package syncthingtray

Syncthing Tray

Qt 5-based tray application for Syncthing

Refresh
Refresh
Source Files
Filename Size Changed
syncthingtray-1.1.19.tar.gz 0001638527 1.56 MB 17 days
syncthingtray-rpmlintrc 0000000060 60 Bytes almost 5 years
syncthingtray.changes 0000007735 7.55 KB 17 days
syncthingtray.spec 0000011701 11.4 KB 17 days
Comments 8

Kai Pastor's avatar

dg0yt wrote over 3 years ago

syninctray is building for 7 days for Fedora_27, looping with:

[618145s] 1: - Connection error: Unable to request Syncthing status: Connection refused'

in this repository and in vcs, cf. https://build.opensuse.org/monitor/old. How about canceling it?


Marius Kittler's avatar

mkittler wrote over 3 years ago

Thanks for letting me know. I disabled the build flag in the repository settings.


Predrag Ivanović's avatar

predivan wrote 6 months ago

Are you considering submitting this to Network/Factory at some point?

qsyncthingtray available there is basically unmaintained upstream, and syncthing-gtk is gtk3/python2 based, and python2 will likely get removed from next Leap release.

Thank you for making it available here, BTW :)


Marius Kittler's avatar

mkittler wrote 6 months ago

My requests were declined (except for c++utilities). As I wasn't willing to spend the extra work I gave up at some point I gave it up. There's actually still an open GitHub issue about it: https://github.com/Martchus/syncthingtray/issues/12


Predrag Ivanović's avatar

predivan wrote 6 months ago

Ah, OK.


Christoph Resch's avatar

trueshanti wrote 4 months ago

in leap15.3 the app complains aboiut wrong module versions:

file:///usr/share/plasma/plasmoids/martchus.syncthingplasmoid/contents/ui/FullRepresentation.qml:3:1: module "QtQuick.Layouts" version 1.15 is not installed


Marius Kittler's avatar

mkittler wrote 4 months ago

Ok, then Qt on Leap 15.3 is too old. I can check whether I can lower the version requirement. If not I suppose one has to stick with an older version of Syncthing Tray as well (not sure how to lock the package for Leap on OBS, especially because the old build has already been replaced) or use the Qt Widgets based version that should still support Qt 5.6.


Marius Kittler's avatar

mkittler wrote 4 months ago

I've been adding a potential fix. Packages are currently rebuilt on https://build.opensuse.org/project/show/home:mkittler:vcs so you can install the possibly fixed version from there. (It needs actually only at least 1.3. I hope Leap 15.3 provides that and that no other version requirements are preventing it to work.)

openSUSE Build Service is sponsored by