Edit Package audacity

A Free, Cross-Platform Digital Audio Editor

Audacity is a program that manipulates digital audio wave forms. In
addition to recording sounds directly from within the program, it
imports many sound file formats, including WAV, AIFF, AU, IRCAM, MP,
and Ogg Vorbis. With Audacity, you can edit wave data larger than the
physical memory size of your computer.

Refresh
Refresh
Source Files (show merged sources derived from linked package)
Filename Size Changed
0001-Adds-an-option-to-disable-Conan.patch 0000009877 9.65 KB 5 months
0001-Fixes-wxwidgets-fixup-script.patch 0000001440 1.41 KB 5 months
0001-Scope-libraries-required-by-the-optional-features.patch 0000001452 1.42 KB 5 months
Audacity-3.0.5.tar.gz 0063066756 60.1 MB 3 months
Fixes-GCC11-compatibility.patch 0000000486 486 Bytes 5 months
_constraints 0000000250 250 Bytes over 1 year
audacity-license-nyquist 0000001344 1.31 KB over 11 years
audacity-misc-errors.patch 0000002084 2.04 KB 10 months
audacity-no_buildstamp.patch 0000002145 2.09 KB 3 months
audacity-no_return_in_nonvoid.patch 0000002262 2.21 KB 5 months
audacity-rpmlintrc 0000000107 107 Bytes almost 7 years
audacity.changes 0000071429 69.8 KB about 2 months
audacity.spec 0000007246 7.08 KB about 2 months
Comments 6

Alexander Ahjolinna's avatar

ahjolinna wrote 7 months ago

Audacity Is Now A Possible Spyware, Remove It ASAP https://fosspost.org/audacity-is-now-a-spyware/


Dave Plater's avatar

plater wrote 5 months ago

Taken from https://fosspost.org/audacity-developers-apologize-revise-controversial-privacy-policy/

What About The Future of Audacity?

For the time being, you can use Audacity versions up to 3.0.2 guaranteeing that they have no network capabilities.

Further I disabled any update checking a long time ago


Yavor Uzunov's avatar

Yav wrote 5 months ago

Version 3.0.3 is out! Maybe the package isn't updated because of privacy concerns? They updated their problematic policy to be better and by default, if you compile it, it compiles without telemetry.


Dave Plater's avatar

plater wrote 5 months ago

It's requirement for Conan which appears to be a package manager will hold it up while I ask why it's there. Also any network connection will have to be disabled.


Dave Plater's avatar

plater wrote 5 months ago

Looks like audacity isn't going to be updated until the conan requirement is fixed. The fork tenacity is only on 3.0.3RC2 so far but if nothing is done by audacity-3.0.4 I'll create tenacity and send to Factory. https://github.com/audacity/audacity/issues/1522


Dave Plater's avatar

plater wrote 5 months ago

3.0.4, heavily patched has an option to disable network access

openSUSE Build Service is sponsored by