Edit Package ffmpeg-4

Library for working with various multimedia formats

https://ffmpeg.org/

FFmpeg is a multimedia framework, able to decode, encode,
transcode, mux, demux, stream, filter and play several formats
that humans and machines have created.

Refresh
Refresh
Source Files (show merged sources derived from linked package)
Filename Size Changed
baselibs.conf 0000000252 252 Bytes 4 months
enable_decoders 0000001871 1.83 KB about 1 year
enable_encoders 0000001576 1.54 KB about 2 months
ffmpeg-4-rpmlintrc 0000000263 263 Bytes over 2 years
ffmpeg-4.2-dlopen-fdk_aac.patch 0000007982 7.79 KB 17 days
ffmpeg-4.4-CVE-2020-22046.patch 0000000734 734 Bytes 17 days
ffmpeg-4.4.tar.xz 0009557868 9.12 MB 4 months
ffmpeg-4.4.tar.xz.asc 0000000520 520 Bytes 4 months
ffmpeg-4.changes 0000072003 70.3 KB 17 days
ffmpeg-4.spec 0000028985 28.3 KB 17 days
ffmpeg-CVE-2021-33815.patch 0000001206 1.18 KB 19 days
ffmpeg-arm6l.diff 0000000502 502 Bytes 4 months
ffmpeg-codec-choice.diff 0000002151 2.1 KB 17 days
ffmpeg-new-coder-errors.diff 0000003174 3.1 KB 4 months
soversion.patch 0000001809 1.77 KB 17 days
vmaf-trim-usr-local.patch 0000001290 1.26 KB 4 months
Comments for ffmpeg-4 8

Hans-Peter Jansen's avatar

frispete wrote about 1 year ago

Unfortunately, this version is binary incompatible to 4.2.3 in some aspects. Chromium crashes when accessing some sites, e.g. https://www.xometry.com/ and push the quote button. Blender cannot export PNG files anymore.


Ismail Dönmez's avatar

namtrac wrote about 1 year ago

Where did the discussion take place? Upstream does care about proper versioning. We should just nudge them.


Jan Engelhardt's avatar

jengelh wrote about 1 year ago

http://ffmpeg.org/pipermail/ffmpeg-devel/2020-July/265694.html


Hans-Peter Jansen's avatar

frispete wrote 12 months ago

Jan, Ismail, just FYI (given, you didn't noticed already).

As it turns out, the issue is related to a ffmpeg bug, introduced in 4.3 series:

https://trac.ffmpeg.org/ticket/8747

It might be appropriate to backport the fix to this package, since it might occur in many related operations. At least Blender 2.83.{2,3} is still affected. I'm going to apply the Blender Upstream fix for this issue right now:

https://developer.blender.org/rB6778ef4dcc6e8d92e3b2ec9b9ecaf1e54e5bf7b5



Hans-Peter Jansen's avatar

frispete wrote 12 months ago

Just sr'ed a fix


Xu Zhao's avatar

nuklly wrote 7 months ago

Why does this package doesn't support smbclient on Leap 15.2/15.3?


Aaron Stern's avatar

ukbeast89 wrote 6 months ago

I notice amf is not enabled. --enable-amf https://github.com/GPUOpen-LibrariesAndSDKs/AMF

Enabling AMF would allow Radeon users to have accelerated encoding, benefit also would allow obs to use accelerated encoding on opensuse.

Users would still need to have access to https://www.amd.com/en/support/kb/release-notes/rn-amdgpu-unified-linux-20-45, but looking on https://wiki.archlinux.org/index.php/FFmpeg#AMD_AMF it is possible to install a small module, rather than the whole driver.

openSUSE Build Service is sponsored by