GTK+ audio player

https://deadbeef.sourceforge.io/

DeaDBeeF is an audio player using GTK+.
Through use of the ffmpeg libraries, it supports many formats.
It also supports cuesheets, chiptune formats with subtunes, song-length databases.
It can be extended using plugins (DSP, GUI, output, input, etc.).
The GUI looks similar to Foobar2000.

Refresh
Refresh
Source Files (show merged sources derived from linked package)
Filename Size Changed Actions
0003-Fix-operator-precedence-and-uninitialized-value-warn.patch 0000001976 1.93 KB almost 2 years
_service 0000000685 685 Bytes 4 months
deadbeef-compiler-warnings.patch 0000005533 5.4 KB 4 months
deadbeef-fix_ubuntu_unity_desktop.patch 0000001186 1.16 KB 7 months
deadbeef.appdata.xml 0000002684 2.62 KB almost 2 years
deadbeef.changes 0000029466 28.8 KB 4 months
deadbeef.spec 0000006845 6.68 KB 4 months
deadbeef_disable_psf.patch 0000004651 4.54 KB 4 months
deadbeef_nopsf-1.8.1.tar.xz 0004995364 4.76 MB 4 months
Comments for deadbeef 3

Aaron Stern's avatar

ukbeast89 wrote 2 months ago

I have no idea on how to make build more verbose, deadbeef-compiler-warnings.patch will fail to compile for Tumbleweed with it enabled.

Should I enable it again?


Ave Milia's avatar

avemilia wrote 2 months ago

The problem occurs in glib header. It can be omitted if include files are specified as -isystem and not as -I. In general, all external dependencies should be included with -isystem or things like these happen.


Ave Milia's avatar

avemilia wrote 2 months ago

How to install the -plugins-extra version? What toggles restricted?