Advanced general-purpose multimedia player

Edit Package mpv
http://mpv.io/

mpv is a movie player based on MPlayer and mplayer2. It supports a wide variety
of video file formats, audio and video codecs, and subtitle types.

Refresh
Refresh
Source Files (show merged sources derived from linked package)
Filename Size Changed
_service 0000000987 987 Bytes
_servicedata 0000000235 235 Bytes
fix-docs-path.patch 0000001325 1.29 KB
mpv-0.37.0+git20231121.2a57a6ee.obscpio 0009871373 9.41 MB
mpv-make-ffmpeg-version-check-non-fatal.patch 0000000639 639 Bytes
mpv.changes 0000245853 240 KB
mpv.obsinfo 0000000114 114 Bytes
mpv.spec 0000008287 8.09 KB
Comments 5

Илья Индиго's avatar

Disable mujs backend for Leap because it's not available there

https://build.opensuse.org/package/show/openSUSE:Backports:SLE-15-SP5/mujs

I don't understand how it can be that it was accepted here, but it didn't make it into Leap 15.5?


llyyr's avatar

Not much I can do about it, you should report a bug I guess


Eric Schirra's avatar

What does a package in factory have to do with Leap?


David Kačerek's avatar

Hi,

the last mpv version 0.36.0 in the Leap 15.5 repo gives me the following error whenever I try to play a video:

mpv: symbol lookup error: mpv: undefined symbol: ass_track_set_feature

I tried to run mpv with disabling several ass-related options I could find in the mpv manpage to no avail:

> mpv --no-sub-ass --sub-ass-override=strip --embeddedfonts=no...

In an upstream issue report, a contributor says it's a downstream build issue: https://github.com/mpv-player/mpv/issues/11042

So can You please rebuild it for the Leap 15.5 against the changed ABIs/APIs if that's possible? I can see the latest version build fails for 15.5, but 0.36.0 is fine.

Thanks.


Enrico Belleri's avatar

This here is the development repo for Factory, there is no branching to keep the package version behind for some specific cases.

15.5 target is not building because libplacebo is too old. libplacebo is too old because meson in 15.5 is too old.

The version included in Leap 15.5 is 0.34.0+git.20211101T154439.9ca9066d05. I believe that to keep using Leap you need to be content with that version.

openSUSE Build Service is sponsored by