Edit Package nextcloud-desktop

Nextcloud desktop synchronisation client

The Nextcloud Desktop Client is a tool to synchronise files from the Nextcloud Server with your computer.

Nextcloud Desktop enables you to connect to your private Nextcloud Server.
With it you can create directories in your home directory, and keep the contents of those directories synced with the server.
Simply copy a file into the directory and the desktop synchronisation client does the rest.

  • Developed at network
  • 2 derived packages
  • Download package
  • osc -A https://api.opensuse.org checkout openSUSE:Factory/nextcloud-desktop && cd $_
  • Create Badge
Refresh
Refresh
Source Files
Filename Size Changed
nextcloud-desktop-3.6.6.tar.gz 0015497450 14.8 MB 12 days
nextcloud-desktop-remove-datetime.patch 0000001354 1.32 KB over 2 years
nextcloud-desktop.changes 0000078634 76.8 KB 12 days
nextcloud-desktop.spec 0000010007 9.77 KB 12 days
sysctl-sync-inotify.conf 0000000037 37 Bytes about 4 years
Comments 4

Frank Scheuer's avatar

Lacerta wrote 7 months ago

Installation fails ====> libQt5Gui.so.5(Qt_5.15.2_PRIVATE_API)(64bit) is missing.


Jos Poortvliet's avatar

jos_poortvliet wrote 7 months ago

Yeap, same here, trying to upgrade: 2 Problems: Problem: the installed nextcloud-desktop-3.5.1-1.1.x86_64 requires 'libQt5Gui.so.5(Qt_5.15.2_PRIVATE_API)(64bit)', but this requirement cannot be provided Problem: the installed libQt5Gui5-5.15.2+kde294-6.1.x86_64 requires 'libQt5Core.so.5(Qt_5.15.2_PRIVATE_API)(64bit)', but this requirement cannot be provided

Problem: the installed nextcloud-desktop-3.5.1-1.1.x86_64 requires 'libQt5Gui.so.5(Qt_5.15.2_PRIVATE_API)(64bit)', but this requirement cannot be provided deleted providers: libQt5Gui5-5.15.2+kde294-6.1.x86_64 Solution 1: Following actions will be done: keep obsolete libQt5Gui5-5.15.2+kde294-6.1.x86_64 keep obsolete libQt5DBus5-5.15.2+kde294-6.1.x86_64 Solution 2: deinstallation of nextcloud-desktop-3.5.1-1.1.x86_64 Solution 3: break nextcloud-desktop-3.5.1-1.1.x86_64 by ignoring some of its dependencies

I'm going to guess that the desktop client will also function with the 5.15.5 version of the library, but sure I am not ;-)


Eric Schirra's avatar

ecsos wrote 7 months ago

Look at the build process, you can see that it was built against 5.15.5. Look at the "Provided by" field next to "libQt5Gui.so.5(Qt_5.15.5_PRIVATE_API)(64bit)" and you will see it is not empty anymore. It's all related to -D_FORTIFY_SOURCE=3. It just takes a little while until it arrives in Tumbleweed. Should be included in the next shnapshot, apparently "20220701".


Jos Poortvliet's avatar

jos_poortvliet wrote 7 months ago

I'm afraid I could not puzzle that out... I'm not exactly a competent packager. But I look forward to the next snapshot, thanks for sharing!

openSUSE Build Service is sponsored by