LogoopenSUSE Build Service > Projects
Sign Up | Log In

Avogadro

An advanced molecular editor designed for cross-platform use in computational chemistry, molecular modeling, bioinformatics, materials science, and related areas. It offers flexible rendering and a powerful plugin architecture.

Source Files

Filename Size Changed Actions
0004-don-t-use-signbit-on-non-float.patch 1.24 KB 11 months ago Download File
0006-Fix-libmsym-libdir-for-64bit.patch 1.53 KB 11 months ago Download File
avogadro-1.1.0-avopkg-fix-echo.patch 1.12 KB almost 4 years ago Download File
avogadro-1.2.0.tar.gz 16 MB about 2 years ago
avogadro-boost.patch 2.64 KB 11 months ago Download File
avogadro-opanbabel.patch 599 Bytes over 2 years ago Download File
avogadro.changes 11.2 KB 8 months ago Download File
avogadro.png 48.3 KB almost 11 years ago Download File
avogadro.spec 6.52 KB 8 months ago Download File
baselibs.conf 111 Bytes about 7 years ago Download File

Comments for science (4)

repo-checker wrote 10 months ago

The version of this package in openSUSE:Leap:15.0 has installation issues and may not be installable:

can't install avogadro-1.1.1-lp150.1.3.x86_64:
  package avogadro-1.1.1-lp150.1.3.x86_64 requires libavogadro.so.1()(64bit), but none of the providers can be installed
  package avogadro-1.1.1-lp150.1.3.x86_64 requires libavogadro_OpenQube.so.0()(64bit), but none of the providers can be installed
  package avogadro-1.1.1-lp150.1.3.x86_64 requires libavogadro1 = 1.1.1, but none of the providers can be installed
  nothing provides libboost_python-py2_7.so.1.65.1()(64bit) needed by libavogadro1-1.1.1-lp150.1.3.x86_64

can't install avogadro-devel-1.1.1-lp150.1.3.x86_64:
  package avogadro-devel-1.1.1-lp150.1.3.x86_64 requires avogadro = 1.1.1, but none of the providers can be installed
  package avogadro-1.1.1-lp150.1.3.x86_64 requires libavogadro.so.1()(64bit), but none of the providers can be installed
  package avogadro-1.1.1-lp150.1.3.x86_64 requires libavogadro_OpenQube.so.0()(64bit), but none of the providers can be installed
  package avogadro-1.1.1-lp150.1.3.x86_64 requires libavogadro1 = 1.1.1, but none of the providers can be installed
  nothing provides libboost_python-py2_7.so.1.65.1()(64bit) needed by libavogadro1-1.1.1-lp150.1.3.x86_64

can't install libavogadro1-1.1.1-lp150.1.3.x86_64:
  nothing provides libboost_python-py2_7.so.1.65.1()(64bit) needed by libavogadro1-1.1.1-lp150.1.3.x86_64

can't install python-avogadro-1.1.1-lp150.1.3.x86_64:
  nothing provides libboost_python-py2_7.so.1.65.1()(64bit) needed by python-avogadro-1.1.1-lp150.1.3.x86_64
fusion809 wrote 7 months ago

One issue I've noticed with this package and that provided by the official repo of Tumbleweed is that when I open a SDF file with it I get an error like:

Reading molecular file failed, file /home/fusion809/Chem/3D/SDF/4M48-Ligands_noHydrogens_withMissing_1_Instances.sdf.

This isn't an issue that Avogadro has to have, on Fedora I do not get this error (same SDF files, so it's not an issue with individual files, I've tried opening several SDF files, like ones from PubChem and ones I've made). Here's what I get when I start Avogadro from the command-line with an SDF file as its argument (i.e. I started it with avogadro /home/fusion809/Chem/3D/SDF/4M48-Ligands_noHydrogens_withMissing_1_Instances.sdf):

"Avogadro version:      1.2.0   Git:
LibAvogadro version:    1.2.0   Git:    " 
Locale:  "en_GB" 
Translation successfully loaded. 
System has OpenGL support. 
About to test OpenGL capabilities. 
OpenGL capabilities found: 
        Double Buffering.
        Direct Rendering.
        Antialiasing.
Loading plugins: "/usr/bin/../lib64/avogadro/1_2" 
Searching for plugins in "/usr/lib64/avogadro/1_2" 
Searching for plugins in "/usr/lib64/avogadro/1_2/colors" 
Searching for plugins in "/usr/lib64/avogadro/1_2/engines" 
Searching for plugins in "/usr/lib64/avogadro/1_2/extensions" 
Searching for plugins in "/usr/lib64/avogadro/1_2/tools" 
Loading plugins: "/home/fusion809/.avogadro/1_2/plugins" 
Unable to set up and use any force fields. 
Settings are missing for the next engines: () 
QStackedLayout::setCurrentWidget: Widget 0x55b8a720d9f0 not contained in stack
dev warning: Extension "GAMESS" is using a deprecated DockWidget loading method. See Extension::dockWidgets() documentation. 
dev warning: Extension "Orbitals" is using a deprecated DockWidget loading method. See Extension::dockWidgets() documentation. 
dev warning: Extension "Python Terminal" is using a deprecated DockWidget loading method. See Extension::dockWidgets() documentation. 
dev warning: Extension "Vibration" is using a deprecated DockWidget loading method. See Extension::dockWidgets() documentation. 
dev warning: Extension "Example Python Extension" is using a deprecated DockWidget loading method. See Extension::dockWidgets() documentation. 
HOMO at:  -1 
GLWidget initialisation... 
GLSL support enabled, OpenGL 2.0 support confirmed. 
GLWidget initialised... 

(avogadro:5492): Gtk-WARNING **: 15:44:17.324: Error loading theme icon 'dialog-warning' for stock: Unrecognised image file format
createObjects() 
libpng warning: iCCP: known incorrect sRGB profile
libpng warning: iCCP: known incorrect sRGB profile
libpng warning: iCCP: known incorrect sRGB profile
libpng warning: iCCP: known incorrect sRGB profile
libpng warning: cHRM: invalid chromaticities
libpng warning: iCCP: known incorrect sRGB profile
StefanBruens wrote 7 months ago

This is not a bug tracker ...

repo-checker wrote 5 months ago

The version of this package in openSUSE:Factory has installation issues and may not be installable:

can't install avogadro-1.2.0-2.2.i586:
  package avogadro-1.2.0-2.2.i586 requires libavogadro.so.1, but none of the providers can be installed
  package avogadro-1.2.0-2.2.i586 requires libavogadro_OpenQube.so.0, but none of the providers can be installed
  package avogadro-1.2.0-2.2.i586 requires libavogadro1 = 1.2.0, but none of the providers can be installed
  nothing provides libboost_python-py2_7.so.1.66.0 needed by libavogadro1-1.2.0-2.2.i586

can't install avogadro-1.2.0-2.2.x86_64:
  package avogadro-1.2.0-2.2.x86_64 requires libavogadro.so.1()(64bit), but none of the providers can be installed
  package avogadro-1.2.0-2.2.x86_64 requires libavogadro_OpenQube.so.0()(64bit), but none of the providers can be installed
  package avogadro-1.2.0-2.2.x86_64 requires libavogadro1 = 1.2.0, but none of the providers can be installed
  nothing provides libboost_python-py2_7.so.1.66.0()(64bit) needed by libavogadro1-1.2.0-2.2.x86_64

can't install avogadro-devel-1.2.0-2.2.i586:
  package avogadro-devel-1.2.0-2.2.i586 requires avogadro = 1.2.0, but none of the providers can be installed
  package avogadro-1.2.0-2.2.i586 requires libavogadro.so.1, but none of the providers can be installed
  package avogadro-1.2.0-2.2.i586 requires libavogadro_OpenQube.so.0, but none of the providers can be installed
  package avogadro-1.2.0-2.2.i586 requires libavogadro1 = 1.2.0, but none of the providers can be installed
  nothing provides libboost_python-py2_7.so.1.66.0 needed by libavogadro1-1.2.0-2.2.i586

can't install avogadro-devel-1.2.0-2.2.x86_64:
  package avogadro-devel-1.2.0-2.2.x86_64 requires avogadro = 1.2.0, but none of the providers can be installed
  package avogadro-1.2.0-2.2.x86_64 requires libavogadro.so.1()(64bit), but none of the providers can be installed
  package avogadro-1.2.0-2.2.x86_64 requires libavogadro_OpenQube.so.0()(64bit), but none of the providers can be installed
  package avogadro-1.2.0-2.2.x86_64 requires libavogadro1 = 1.2.0, but none of the providers can be installed
  nothing provides libboost_python-py2_7.so.1.66.0()(64bit) needed by libavogadro1-1.2.0-2.2.x86_64

can't install avogadro-devel-32bit-1.2.0-2.2.x86_64:
  package avogadro-devel-32bit-1.2.0-2.2.x86_64 requires libavogadro1-32bit = 1.2.0, but none of the providers can be installed
  nothing provides libboost_python-py2_7.so.1.66.0 needed by libavogadro1-32bit-1.2.0-2.2.x86_64

can't install libavogadro1-1.2.0-2.2.i586:
  nothing provides libboost_python-py2_7.so.1.66.0 needed by libavogadro1-1.2.0-2.2.i586

can't install libavogadro1-1.2.0-2.2.x86_64:
  nothing provides libboost_python-py2_7.so.1.66.0()(64bit) needed by libavogadro1-1.2.0-2.2.x86_64

can't install libavogadro1-32bit-1.2.0-2.2.x86_64:
  nothing provides libboost_python-py2_7.so.1.66.0 needed by libavogadro1-32bit-1.2.0-2.2.x86_64

can't install python-avogadro-1.2.0-2.2.i586:
  nothing provides libboost_python-py2_7.so.1.66.0 needed by python-avogadro-1.2.0-2.2.i586

can't install python-avogadro-1.2.0-2.2.x86_64:
  nothing provides libboost_python-py2_7.so.1.66.0()(64bit) needed by python-avogadro-1.2.0-2.2.x86_64

Login required, please login or signup in order to comment