LogoopenSUSE Build Service > Projects
Sign Up | Log In

MathGL
http://mathgl.sourceforge.net

MathGL is a cross-platform library for making high-quality scientific graphics. It provides fast data plotting and handling of large data arrays, as well as  window and console modes and for easy embedding into other programs. MathGL integrates into FLTK, Qt and OpenGL applications.

Source Files (show merged sources derived from linked package)

Filename Size Changed Actions
_constraints 129 Bytes about 1 year ago Download File
mathgl-2.4.2.tar.gz 21.6 MB 6 months ago
mathgl-doc-path.patch 663 Bytes about 1 year ago Download File
mathgl-examples-install.patch 2.3 KB 6 months ago Download File
mathgl-fix-python-module-path.patch 751 Bytes about 1 year ago Download File
mathgl-fltk-includedir.patch 2.36 KB about 1 year ago Download File
mathgl-no-default-qt.patch 1.01 KB 10 months ago Download File
mathgl-rpmlintrc 105 Bytes almost 2 years ago Download File
mathgl-texmf-dir.patch 1.49 KB about 1 year ago Download File
mathgl.changes 28.1 KB 5 months ago Download File
mathgl.spec 22.5 KB 5 months ago Download File
udav-help-path.patch 442 Bytes about 1 year ago Download File

Comments for science (1)

repo-checker wrote 8 months ago

The version of this package in openSUSE:Leap:15.0 has installation issues and may not be installable:

can't install libmgl-fltk7_5_0-2.4.1-lp150.2.7.x86_64:
  package libmgl-fltk7_5_0-2.4.1-lp150.2.7.x86_64 requires libmgl.so.7.5.0()(64bit), but none of the providers can be installed
  nothing provides libhpdf-2.2.1.so()(64bit) needed by libmgl7_5_0-2.4.1-lp150.2.7.x86_64

can't install libmgl-glut7_5_0-2.4.1-lp150.2.7.x86_64:
  package libmgl-glut7_5_0-2.4.1-lp150.2.7.x86_64 requires libmgl.so.7.5.0()(64bit), but none of the providers can be installed
  nothing provides libhpdf-2.2.1.so()(64bit) needed by libmgl7_5_0-2.4.1-lp150.2.7.x86_64

can't install libmgl-qt5-7_5_0-2.4.1-lp150.2.7.x86_64:
  package libmgl-qt5-7_5_0-2.4.1-lp150.2.7.x86_64 requires libmgl.so.7.5.0()(64bit), but none of the providers can be installed
  nothing provides libhpdf-2.2.1.so()(64bit) needed by libmgl7_5_0-2.4.1-lp150.2.7.x86_64

can't install libmgl-wnd7_5_0-2.4.1-lp150.2.7.x86_64:
  package libmgl-wnd7_5_0-2.4.1-lp150.2.7.x86_64 requires libmgl.so.7.5.0()(64bit), but none of the providers can be installed
  nothing provides libhpdf-2.2.1.so()(64bit) needed by libmgl7_5_0-2.4.1-lp150.2.7.x86_64

can't install libmgl-wx7_5_0-2.4.1-lp150.2.7.x86_64:
  package libmgl-wx7_5_0-2.4.1-lp150.2.7.x86_64 requires libmgl.so.7.5.0()(64bit), but none of the providers can be installed
  nothing provides libhpdf-2.2.1.so()(64bit) needed by libmgl7_5_0-2.4.1-lp150.2.7.x86_64

can't install libmgl7_5_0-2.4.1-lp150.2.7.x86_64:
  nothing provides libhpdf-2.2.1.so()(64bit) needed by libmgl7_5_0-2.4.1-lp150.2.7.x86_64

can't install mathgl-cgi-2.4.1-lp150.2.7.x86_64:
  package mathgl-cgi-2.4.1-lp150.2.7.x86_64 requires libmgl.so.7.5.0()(64bit), but none of the providers can be installed
  nothing provides libhpdf-2.2.1.so()(64bit) needed by libmgl7_5_0-2.4.1-lp150.2.7.x86_64

can't install mathgl-devel-2.4.1-lp150.2.7.x86_64:
  package mathgl-devel-2.4.1-lp150.2.7.x86_64 requires libmgl7_5_0 = 2.4.1, but none of the providers can be installed
  nothing provides libhpdf-2.2.1.so()(64bit) needed by libmgl7_5_0-2.4.1-lp150.2.7.x86_64

can't install mathgl-devel-static-2.4.1-lp150.2.7.x86_64:
  package mathgl-devel-static-2.4.1-lp150.2.7.x86_64 requires mathgl-devel = 2.4.1, but none of the providers can be installed
  package mathgl-devel-2.4.1-lp150.2.7.x86_64 requires libmgl7_5_0 = 2.4.1, but none of the providers can be installed
  nothing provides libhpdf-2.2.1.so()(64bit) needed by libmgl7_5_0-2.4.1-lp150.2.7.x86_64

can't install mathgl-examples-2.4.1-lp150.2.7.x86_64:
  nothing provides libhpdf-2.2.1.so()(64bit) needed by mathgl-examples-2.4.1-lp150.2.7.x86_64

can't install mathgl-lang-2.4.1-lp150.2.7.noarch:
  package mathgl-lang-2.4.1-lp150.2.7.noarch requires mathgl = 2.4.1, but none of the providers can be installed
  nothing provides libhpdf-2.2.1.so()(64bit) needed by libmgl7_5_0-2.4.1-lp150.2.7.x86_64

can't install mathgl-lua-2.4.1-lp150.2.7.x86_64:
  package mathgl-lua-2.4.1-lp150.2.7.x86_64 requires libmgl.so.7.5.0()(64bit), but none of the providers can be installed
  nothing provides libhpdf-2.2.1.so()(64bit) needed by libmgl7_5_0-2.4.1-lp150.2.7.x86_64

can't install mathgl-tex-2.4.1-lp150.2.7.noarch:
  package mathgl-tex-2.4.1-lp150.2.7.noarch requires mathgl-tools >= 2.4.1, but none of the providers can be installed
  package mathgl-tools-2.4.1-lp150.2.7.x86_64 requires libmgl.so.7.5.0()(64bit), but none of the providers can be installed
  nothing provides libhpdf-2.2.1.so()(64bit) needed by libmgl7_5_0-2.4.1-lp150.2.7.x86_64

can't install mathgl-tools-2.4.1-lp150.2.7.x86_64:
  package mathgl-tools-2.4.1-lp150.2.7.x86_64 requires libmgl.so.7.5.0()(64bit), but none of the providers can be installed
  nothing provides libhpdf-2.2.1.so()(64bit) needed by libmgl7_5_0-2.4.1-lp150.2.7.x86_64

can't install python-mathgl-2.4.1-lp150.2.7.x86_64:
  package python-mathgl-2.4.1-lp150.2.7.x86_64 requires libmgl.so.7.5.0()(64bit), but none of the providers can be installed
  nothing provides libhpdf-2.2.1.so()(64bit) needed by libmgl7_5_0-2.4.1-lp150.2.7.x86_64

can't install udav-2.4.1-lp150.2.7.x86_64:
  package udav-2.4.1-lp150.2.7.x86_64 requires libmgl.so.7.5.0()(64bit), but none of the providers can be installed
  nothing provides libhpdf-2.2.1.so()(64bit) needed by libmgl7_5_0-2.4.1-lp150.2.7.x86_64

Login required, please login or signup in order to comment