octave-forge-interval

The interval package for real-valued interval arithmetic allows to evaluate functions over subsets of their domain. All results are verified, because interval computations automatically keep track of any errors.
These concepts can be used to handle uncertainties, estimate arithmetic errors and produce reliable results. Also it can be applied to computer-assisted proofs, constraint programming, and verified computing.
The implementation is based on interval boundaries represented by binary64 numbers and is conforming to IEEE Std 1788-2015, IEEE standard for interval arithmetic.
This is part of Octave-Forge project.

Refresh
Refresh
Source Files (show merged sources derived from linked package)
Filename Size Changed Actions
interval-3.2.0.tar.gz 0002672463 2.55 MB about 1 year
octave-forge-interval.changes 0000007589 7.41 KB about 1 year
octave-forge-interval.spec 0000002373 2.32 KB about 1 year
Comments for octave-forge-interval 2

Repo Checker

repo-checker wrote over 1 year ago

The version of this package in openSUSE:Leap:15.0 has installation issues and may not be installable:

can't install octave-forge-interval-3.0.0-lp150.1.2.x86_64:
  nothing provides libmpfr.so.4()(64bit) needed by octave-forge-interval-3.0.0-lp150.1.2.x86_64

Repo Checker

repo-checker wrote about 1 year ago

The version of this package in openSUSE:Factory has installation issues and may not be installable:

can't install octave-forge-interval-3.0.0-1.4.i586:
  package octave-forge-interval-3.0.0-1.4.i586 requires liboctave.so.5, but none of the providers can be installed
  package octave-forge-interval-3.0.0-1.4.i586 requires liboctinterp.so.5, but none of the providers can be installed
  package octave-forge-interval-3.0.0-1.4.i586 requires octave-cli >= 3.8.2, but none of the providers can be installed
  nothing provides libamd-2.4.6.so needed by octave-cli-4.4.0-1.1.i586
  nothing provides libccolamd-2.9.6.so needed by octave-cli-4.4.0-1.1.i586
  nothing provides libcholmod-3.0.11.so needed by octave-cli-4.4.0-1.1.i586
  nothing provides libcolamd-2.9.6.so needed by octave-cli-4.4.0-1.1.i586
  nothing provides libcxsparse-3.1.9.so needed by octave-cli-4.4.0-1.1.i586
  nothing provides libsuitesparseconfig-4.5.5.so needed by octave-cli-4.4.0-1.1.i586
  nothing provides libumfpack-5.7.6.so needed by octave-cli-4.4.0-1.1.i586

can't install octave-forge-interval-3.0.0-1.4.x86_64:
  package octave-forge-interval-3.0.0-1.4.x86_64 requires octave-cli >= 3.8.2, but none of the providers can be installed
  package octave-forge-interval-3.0.0-1.4.x86_64 requires liboctave.so.5()(64bit), but none of the providers can be installed
  package octave-forge-interval-3.0.0-1.4.x86_64 requires liboctinterp.so.5()(64bit), but none of the providers can be installed
  nothing provides libamd-2.4.6.so()(64bit) needed by octave-cli-4.4.0-1.1.x86_64
  nothing provides libccolamd-2.9.6.so()(64bit) needed by octave-cli-4.4.0-1.1.x86_64
  nothing provides libcholmod-3.0.11.so()(64bit) needed by octave-cli-4.4.0-1.1.x86_64
  nothing provides libcolamd-2.9.6.so()(64bit) needed by octave-cli-4.4.0-1.1.x86_64
  nothing provides libcxsparse-3.1.9.so()(64bit) needed by octave-cli-4.4.0-1.1.x86_64
  nothing provides libsuitesparseconfig-4.5.5.so()(64bit) needed by octave-cli-4.4.0-1.1.x86_64
  nothing provides libumfpack-5.7.6.so()(64bit) needed by octave-cli-4.4.0-1.1.x86_64