Update for gnuplot.openSUSE_Leap_15.0_Update security moderate

Security update for gnuplot

This update for gnuplot fixes the following issues:

Security issues fixed:

- CVE-2018-19492: Fixed a buffer overflow in cairotrm_options function (bsc#1117463)
- CVE-2018-19491: Fixed a buffer overlow in the PS_options function (bsc#1117464)
- CVE-2018-19490: Fixed a heap-based buffer overflow in the df_generate_ascii_array_entry function (bsc#1117465)

This update was imported from the SUSE:SLE-15:Update update project.

Fixed bugs
bnc#1117465
VUL-1: CVE-2018-19490: gnuplot: an attacker can conduct a heap-based buffer overflow with an arbitrary amount of data in df_generate_ascii_array_entry
bnc#1117464
VUL-1: CVE-2018-19491: gnuplot: an attacker can conduct a buffer overflow with an arbitrary amount of data in the PS_options function
bnc#1117463
VUL-1: CVE-2018-19492: gnuplot: an attacker can conduct a buffer overflow with an arbitrary amount of data in the cairotrm_options function
Selected Binaries
openSUSE Build Service is sponsored by