File extensions-esbuild_version.patch of Package code

Do not expect a specific esbuild version.

--- a/extensions/node_modules/esbuild/install.js
+++ b/extensions/node_modules/esbuild/install.js
@@ -92,7 +92,7 @@
     }
     throw err;
   }
-  if (stdout !== versionFromPackageJSON) {
+  if (0) {
     throw new Error(`Expected ${JSON.stringify(versionFromPackageJSON)} but got ${JSON.stringify(stdout)}`);
   }
 }
--- a/extensions/node_modules/esbuild/lib/main.js
+++ b/extensions/node_modules/esbuild/lib/main.js
@@ -710,7 +710,6 @@
       isFirstPacket = false;
       let binaryVersion = String.fromCharCode(...bytes);
       if (binaryVersion !== "0.20.0") {
-        throw new Error(`Cannot start service: Host version "${"0.20.0"}" does not match binary version ${quote(binaryVersion)}`);
       }
       return;
     }
openSUSE Build Service is sponsored by