Martin Hauke's avatar

Martin Hauke

mnhauke

Involved Projects and Packages
Maintainer

WildMidi is a software midi player which has a core softsynth library that can
be used with other applications.

Maintainer

The BIRD project aims to develop a fully functional dynamic IP routing daemon
primarily targeted on (but not limited to) Linux, FreeBSD and other UNIX-like
systems

Maintainer

clatd implements the CLAT component of the 464XLAT network architecture
specified in RFC 6877. It allows an IPv6-only host to have IPv4
connectivity that is translated to IPv6 before being routed to an upstream
PLAT (which is typically a Stateful NAT64 operated by the ISP) and there
translated back to IPv4 before being routed to the IPv4 internet.

Maintainer
Maintainer

Set of tools to perform basic audits on your DNS requests and responses to make sure your DNS is working as you expect. Dnsping can be used to measure the response time of a given DNS server for arbitrary requests. Just like a traditional ping utility, it provides similar functionality for DNS requests.

Dnstraceroute can be used to trace the path a DNS request takes to destination. Its purpose is to detect whether a request is redirected or hijacked. This can be done by comparing different DNS queries being sent to the same DNS server using dnstraceroute and observe if there is any difference between the path.

dnseval evaluates multiple DNS resolvers and helps you choose the best DNS server for your network. It is highly recommended to use your own DNS resolver as opposed to a third-party DNS server, but in case you need to choose the best DNS forwarder for your network, dnseval lets you compare different DNS servers from performance (latency) and reliability (loss) point of view.

Maintainer
Maintainer

DSVPN is a Dead Simple VPN, designed to address the most common
use case for using a VPN:

[client device] -- (untrusted network) -- [vpn server] -- [the Internet]

Features:
* Runs on TCP. Works pretty much everywhere, including on public WiFi
where only TCP/443 is open or reliable.
* Uses only modern cryptography, with formally verified implementations.
* Small and constant memory footprint. Doesn't perform any heap memory
allocations.
* Small (~25 KB), with an equally small and readable code base.
* Works out of the box. No lousy documentation to read. No configuration
file. No post-configuration. Run a single-line command on the server,
a similar one on the client and you're done.
No firewall and routing rules to manually mess with.
* Doesn't leak between reconnects if the network doesn't change.
Blocks IPv6 on the client to prevent IPv6 leaks.

Maintainer

FRR is free software which manages TCP/IP based routing protocols.
It supports BGP4, BGP4+, OSPFv2, OSPFv3, IS-IS, RIPv1, RIPv2, RIPng,
PIM and LDP as well as the IPv6 versions of these.

FRR is a fork of Quagga..

Maintainer

fwknop stands for the "FireWall KNock OPerator", and implements an authorization scheme called Single Packet Authorization (SPA).

Maintainer

The FireWall KNock OPerator implements an authorization scheme called
Single Packet Authorization (SPA), based on Netfilter and libpcap.

Its main application is to protect services such as OpenSSH with an
additional layer of security in order to make the exploitation of
vulnerabilities (both 0-day and unpatched code) much more difficult.

Fwknop GUI is a graphical user interface integrated with an Fwknop
client that provides the ability to send SPA packets to a remote
Fwknop server, as well as a front-end for creating and managing client
configurations for multiple Fwknop servers.

It supports exporting saved configuration data to a QR code format
readable by the Android client, as well as to the .fwknoprc format
readable by the command line client.

Maintainer

Glorytun is a small, simple and secure VPN over MUD.
MUD (Multipath UDP Deflector) is a secure, multipath network protocol
over UDP.

The key features of Glorytun come directly from MUD:
* Fast and highly secure
* Multipath and failover
* Traffic shaping
* Path MTU discovery without ICMP

Maintainer

GoBGP is an open source BGP implementation designed from scratch for
modern environment and implemented in Go. It is designed to exploit
multicore processors and can be easily integrated with othersoftware
through an RPC API.

Maintainer

A GSSAPI Mechanism that implements NTLMSSP

Maintainer

Inverse ARP (InARP) daemon for Linux.

Maintainer
Maintainer
Maintainer

llmnrd is a daemon implementing the Link-Local Multicast Name Resolution (LLMNR)
protocol according to RFC 4795. It currently only supports Linux, as it uses the
netlink kernel interface.

llmnrd will respond to name resolution queries sent by Windows clients in
networks where no DNS server is available. It supports both IPv4 and IPv6.

Maintainer
Maintainer

ndppd is a daemon that proxies certain IPv6 NDP messages between two or more
interfaces. It currently supports proxying Neighbor Solicitation Messages
and Neighbor Advertisement messages in order to allow IPv6 routing without
relying on Linux "proxy_ndp".

The daemon is partially compliant with (experimental) RFC4389.

Maintainer

OpenBFDD is an open source package that provides a software based
implantation of the Bidirectional Forwarding Detection (BFD) protocol. It
is designed to run on a server. Its primary purpose is to allow the
administrator to quickly take the server off-line when the core service,
such as a bind or unbound server, goes down. This is done by providing a
BFD "beacon", bfdd-beacon, that can communicate with a properly
configured, BFD enabled, router. A control utility, bfdd-control, can be
used to configure the running bfdd-beacon daemon, and to change the state
of its BFD sessions.

Maintainer

bgpd is a Border Gateway Protocol (BGP) daemon which manages the network
routing tables. Its main purpose is to exchange information concerning “network
reachability” with other BGP systems. bgpd uses the Border Gateway Protocol,
Version 4, as described in RFC 4271.

Maintainer

pTFTPd is a collection of tools related to TFTP. It includes a TFTP server,
a TFTP client, and a complete PXE solution based on this TFTP server and a
micro-DHCP or BOOTP server. All these tools are written in Python and designed
to be fast, RFC compliant and easy to use.

Available tools include:
* bootpd : a BOOTP server (RFC951 and RFC1497 compliant)
* dhcpd : a simple, stripped-down DHCP server.
* ptftpd : the TFTP server (RFC1350, 2347, 2348 and 2349 compliant)
* pxed : a one-call PXE server using dhcpd and ptftpd.
* ptftp : a simple TFTP client (RFC1350, 2347, 2348 and 2349 compliant
and capable)

Maintainer

Perform lookups by ip address and return ASN, Country Code,
and Netblock Owner.

Maintainer

The radcli library is a library for writing RADIUS Clients. The library's
approach is to allow writing RADIUS-aware application in less than 50 lines
of C code. It was based originally on freeradius-client and is source compatible
with it.

Maintainer

Multithreaded TFTP Server and Client implemented in Rust.

openSUSE Build Service is sponsored by