A KDE Photo Manager

Edit Package digikam

digiKam is a simple digital photo management application for KDE, which
allows you to import and organize your digital photos easily. The
photos can be organized in albums, which can be sorted chronologically,
by directory layout, or by custom collections. An easy-to-use interface
that enables you to connect to your camera and preview, download, or
delete your images, is provided.

Refresh
Refresh
Source Files
Filename Size Changed
0001-Look-for-each-akonadi-component-separately.patch 0000001534 1.5 KB
_constraints 0000000110 110 Bytes
digiKam-8.3.0-1.tar.xz 0055664168 53.1 MB
digiKam-8.3.0-1.tar.xz.sig 0000000833 833 Bytes
digikam.changes 0000163688 160 KB
digikam.keyring 0000003106 3.03 KB
digikam.spec 0000008096 7.91 KB
Comments 12

Luz Paz's avatar

Please update to digiKam 6.0


Wolfgang Bauer's avatar

It's on the way: https://build.opensuse.org/request/show/679901

And JFYI: it's not always easy to do such a major version upgrade.
In this particular case, digikam 6.0 doesn't contain kipi-plugins anymore, but that's still used by other applications (spectacle, gwenview, kphotoalbum).
So we had to create a stand-alone kipi-plugins package first, and that had to go through legal review first where it was stuck for 11 days...


zy l's avatar

Today I tried to install digikam using zypper, but was surprised to find that it requires libKF5AkonadiContact5 (libKF5AkonadiContact.so.5), by requiring libdigikamcore6 (libdigikamcore.so.6.1.0).

After I told zypper to break the dependency on akonadi contact and installed digikam, it won't start, complaining "digikam: error while loading shared libraries: libKF5AkonadiContact.so.5: cannot open shared object file: No such file or directory".

It seems not reasonable that digikam as a photo management software should "require" akonadi contact. Is it possible to make akonadi contact only a "recommend" or "suggest" of digikam?


Christophe Giboudeaux's avatar

Is it possible to make akonadi contact only a "recommend" or "suggest" of digikam?

No.


Fabian Vogt's avatar

You need to raise that with the digikam authors. Currently if akonadi integration is enabled during buildtime, it's a hard runtime requirement as well.


Ilgaz Öcal's avatar

Currently broken with openSUSE TW update. digikam: symbol lookup error: /usr/lib64/libdigikamgui.so.7.2.0: undefined symbol: _ZN2cv3dnn14dnn4_v202011173NetC1Ev



Konstantin Shtepa's avatar

Please, change dependency (of libdigikamcore8) from libKF5AkonadiContact to libKPim5AkonadiContact so digikam can be installed on systems with up-to-date kde. It should work fine with libKPim5AkonadiContact as authors said that for time being there will be backwards compatibility for libKPim5AkonadiContact so programs which need libKF5AkonadiContact would work fine with libKPim5AkonadiContact. Tested it with "sudo ln -s /usr/lib64/libKPim5AkonadiContact.so.5 /usr/lib64/libKF5AkonadiContact.so.5", digikam works fine.


Episteme PROMENEUR's avatar

since Sun Dec 3, 2023 version has been published 8.2. Please supply this version.


Laubblaeser's avatar

Yes, please! Is there something lacking in the specifications for automatic building of the newer versions? (I have no experience with OBS, sorry.)


Wolfgang Bauer's avatar

I've submitted the update: SR#1138994

There is no "automatic building of the newer versions" at all. The package has to be updated manually to build a newer version...

openSUSE Build Service is sponsored by