LogoopenSUSE Build Service > Projects
Sign Up | Log In

An optimized BLAS library based on GotoBLAS2

OpenBLAS is an optimized BLAS library based on GotoBLAS2 1.13 BSD version.

Source Files (show merged sources derived from linked package)

Filename Size Changed Actions
README.HPC.SUSE 889 Bytes 9 months ago Download File
README.SUSE 851 Bytes about 3 years ago Download File
_constraints 171 Bytes about 1 year ago Download File
_multibuild 180 Bytes 10 months ago Download File
c_xerbla_no-void-return.patch 367 Bytes about 4 years ago Download File
fix-arm64-cpuid-return.patch 584 Bytes 10 months ago Download File
openblas-0.2.20.tar.gz 11.1 MB 11 months ago
openblas-noexecstack.patch 1.16 KB 11 months ago Download File
openblas-s390.patch 1.04 KB 5 months ago Download File
openblas.changes 17.2 KB 5 months ago Download File
openblas.spec 13.2 KB 5 months ago Download File

Comments for science (1)

Repo Checker repo-checker wrote 4 months ago

The version of this package in openSUSE:Leap:15.0 has installation issues and may not be installable:

can't install libopenblas-gnu-hpc-devel-0.2.20-lp150.5.1.x86_64:
  package libopenblas_0_2_20-gnu-hpc-devel-0.2.20-lp150.5.1.x86_64 requires gnu-compilers-hpc-devel, but none of the providers can be installed
  package gnu-compilers-hpc-devel-1.3-lp150.4.1.noarch requires gcc-c++, but none of the providers can be installed
  package libopenblas-gnu-hpc-devel-0.2.20-lp150.5.1.x86_64 requires libopenblas_0_2_20-gnu-hpc-devel = 0.2.20, but none of the providers can be installed
  package gcc-c++-7-lp150.1.27.x86_64 requires gcc7-c++, but none of the providers can be installed
  nothing provides libmpfr.so.4()(64bit) needed by gcc7-c++-7.3.0+r257042-lp150.1.3.x86_64

can't install libopenblas-pthreads-gnu-hpc-devel-0.2.20-lp150.5.1.x86_64:
  package libopenblas-pthreads_0_2_20-gnu-hpc-devel-0.2.20-lp150.5.1.x86_64 requires gnu-compilers-hpc-devel, but none of the providers can be installed
  package gnu-compilers-hpc-devel-1.3-lp150.4.1.noarch requires gcc-c++, but none of the providers can be installed
  package libopenblas-pthreads-gnu-hpc-devel-0.2.20-lp150.5.1.x86_64 requires libopenblas-pthreads_0_2_20-gnu-hpc-devel = 0.2.20, but none of the providers can be installed
  package gcc-c++-7-lp150.1.27.x86_64 requires gcc7-c++, but none of the providers can be installed
  nothing provides libmpfr.so.4()(64bit) needed by gcc7-c++-7.3.0+r257042-lp150.1.3.x86_64

can't install libopenblas-pthreads_0_2_20-gnu-hpc-devel-0.2.20-lp150.5.1.x86_64:
  package gnu-compilers-hpc-devel-1.3-lp150.4.1.noarch requires gcc-c++, but none of the providers can be installed
  package libopenblas-pthreads_0_2_20-gnu-hpc-devel-0.2.20-lp150.5.1.x86_64 requires gnu-compilers-hpc-devel, but none of the providers can be installed
  package gcc-c++-7-lp150.1.27.x86_64 requires gcc7-c++, but none of the providers can be installed
  nothing provides libmpfr.so.4()(64bit) needed by gcc7-c++-7.3.0+r257042-lp150.1.3.x86_64

can't install libopenblas_0_2_20-gnu-hpc-devel-0.2.20-lp150.5.1.x86_64:
  package gnu-compilers-hpc-devel-1.3-lp150.4.1.noarch requires gcc-c++, but none of the providers can be installed
  package libopenblas_0_2_20-gnu-hpc-devel-0.2.20-lp150.5.1.x86_64 requires gnu-compilers-hpc-devel, but none of the providers can be installed
  package gcc-c++-7-lp150.1.27.x86_64 requires gcc7-c++, but none of the providers can be installed
  nothing provides libmpfr.so.4()(64bit) needed by gcc7-c++-7.3.0+r257042-lp150.1.3.x86_64

can't install openblas-pthreads_0_2_20-gnu-hpc-devel-static-0.2.20-lp150.5.1.x86_64:
  package libopenblas-pthreads_0_2_20-gnu-hpc-devel-0.2.20-lp150.5.1.x86_64 requires gnu-compilers-hpc-devel, but none of the providers can be installed
  package gnu-compilers-hpc-devel-1.3-lp150.4.1.noarch requires gcc-c++, but none of the providers can be installed
  package openblas-pthreads_0_2_20-gnu-hpc-devel-static-0.2.20-lp150.5.1.x86_64 requires libopenblas-pthreads_0_2_20-gnu-hpc-devel = 0.2.20, but none of the providers can be installed
  package gcc-c++-7-lp150.1.27.x86_64 requires gcc7-c++, but none of the providers can be installed
  nothing provides libmpfr.so.4()(64bit) needed by gcc7-c++-7.3.0+r257042-lp150.1.3.x86_64

can't install openblas_0_2_20-gnu-hpc-devel-static-0.2.20-lp150.5.1.x86_64:
  package libopenblas_0_2_20-gnu-hpc-devel-0.2.20-lp150.5.1.x86_64 requires gnu-compilers-hpc-devel, but none of the providers can be installed
  package gnu-compilers-hpc-devel-1.3-lp150.4.1.noarch requires gcc-c++, but none of the providers can be installed
  package openblas_0_2_20-gnu-hpc-devel-static-0.2.20-lp150.5.1.x86_64 requires libopenblas_0_2_20-gnu-hpc-devel = 0.2.20, but none of the providers can be installed
  package gcc-c++-7-lp150.1.27.x86_64 requires gcc7-c++, but none of the providers can be installed
  nothing provides libmpfr.so.4()(64bit) needed by gcc7-c++-7.3.0+r257042-lp150.1.3.x86_64