LogoopenSUSE Build Service > Projects
Sign Up | Log In

IP Packet Filter Administration Extensions
http://xtables-addons.sf.net/

Xtables is used to set up, maintain, and inspect the tables of IP
packet filter rules in the Linux kernel.

Xtables-addons is the successor to patch-o-matic(-ng). Likewise, it
contains extensions that were not, or are not yet, accepted in the
main kernel/iptables packages.

Source Files (show merged sources derived from linked package)

Filename Size Changed Actions
xtables-addons-3.3.tar.asc 833 Bytes Download File
xtables-addons-3.3.tar.xz 315 KB Download File
xtables-addons-preamble 90 Bytes Download File
xtables-addons.changes 13.7 KB Download File
xtables-addons.keyring 5.48 KB Download File
xtables-addons.spec 3.31 KB Download File

Comments for security:netfilter (6)

repo-checker wrote over 1 year ago

The version of this package in openSUSE:Factory has installation issues and may not be installable:

can't install xtables-addons-kmp-pae-2.13_k4.13.10_1-1.26.i586:
  nothing provides kernel-pae needed by xtables-addons-kmp-pae-2.13_k4.13.10_1-1.26.i586
  nothing provides kernel-uname-r = 4.13.10-1-pae needed by xtables-addons-kmp-pae-2.13_k4.13.10_1-1.26.i586
    (we have kernel-default-base-4.13.10-1.3.i586)
    (we have kernel-default-4.13.10-1.3.i586)
Phazeus wrote over 1 year ago

Please add libelf-devel for xtables-addons-kmp-default x86_64

jengelh wrote over 1 year ago

If it is that important, libelf-devel should be added to kernel-devel rather than trying to hand-edit every KMP under the sun :-/ cc @mmarek

Phazeus wrote over 1 year ago

Just openSUSE repository has issue with building this package, I can't update my system :(

repo-checker wrote 8 months ago

The version of this package in openSUSE:Factory has installation issues and may not be installable:

can't install xtables-addons-kmp-pae-3.2_k4.18.8_1-1.3.i586:
  nothing provides kernel-pae needed by xtables-addons-kmp-pae-3.2_k4.18.8_1-1.3.i586
  nothing provides kernel-uname-r = 4.18.8-1-pae needed by xtables-addons-kmp-pae-3.2_k4.18.8_1-1.3.i586
    (we have kernel-default-base-4.18.8-1.3.i586)
    (we have kernel-default-4.18.8-1.3.i586)
repo-checker wrote 8 months ago

The version of this package in openSUSE:Leap:15.1 has installation issues and may not be installable:

can't install xtables-addons-kmp-default-2.14_k4.12.14_lp151.16-lp151.3.9.x86_64:
  nothing provides ksym(default: needed by xtables-addons-kmp-default-2.14_k4.12.14_lp151.16-lp151.3.9.x86_64
  nothing provides ksym(default:) needed by xtables-addons-kmp-default-2.14_k4.12.14_lp151.16-lp151.3.9.x86_64
  nothing provides ksym(default:nload needed by xtables-addons-kmp-default-2.14_k4.12.14_lp151.16-lp151.3.9.x86_64
  nothing provides modversions needed by xtables-addons-kmp-default-2.14_k4.12.14_lp151.16-lp151.3.9.x86_64
  nothing provides retpoline needed by xtables-addons-kmp-default-2.14_k4.12.14_lp151.16-lp151.3.9.x86_64

Login required, please login or signup in order to comment