mc

http://www.midnight-commander.org/

GNU Midnight Commander is a visual file manager, licensed under GNU General Public License and therefore qualifies as Free Software. It's a feature rich full-screen text mode application that allows you to copy, move and delete files and whole directory trees, search for files and run commands in the subshell. Internal viewer and editor are included.

Refresh
Refresh
Source Files (show merged sources derived from linked package)
Filename Size Changed Actions
20_wrong_path_to_wrappers.patch 0000000988 988 Bytes almost 10 years
_service 0000000556 556 Bytes 8 days
cmake.syntax 0000013954 13.6 KB about 8 years
mc-4.8.25.sha256 0000000167 167 Bytes 8 days
mc-4.8.25.tar.xz 0002488324 2.37 MB 8 days
mc-esc-seq.patch 0000000395 395 Bytes over 4 years
mc-ext-audio.patch 0000001260 1.23 KB 8 days
mc-extd-doc.patch 0000000854 854 Bytes over 1 year
mc-extd-misc.patch 0000000518 518 Bytes over 7 years
mc-extd-sound.patch 0000001607 1.57 KB 8 days
mc-extd-video.patch 0000000977 977 Bytes over 1 year
mc-extd-xdg.patch 0000003643 3.56 KB over 4 years
mc-extfs-helpers-deb.patch 0000000942 942 Bytes about 8 years
mc-extfs-iso9660-xorriso.patch 0000000742 742 Bytes over 6 years
mc-f-keys.patch 0000000804 804 Bytes over 4 years
mc-fix_lib_search_path.patch 0000001154 1.13 KB over 4 years
mc-multi-press-f-keys.patch 0000002112 2.06 KB about 1 year
mc-pie.patch 0000000308 308 Bytes over 7 years
mc-startup-timeout.patch 0000001193 1.17 KB over 4 years
mc-vfs-fish-deleted_source_file.patch 0000005006 4.89 KB over 1 year
mc-wrapper.patch 0000001486 1.45 KB over 5 years
mc.changes 0000067297 65.7 KB 7 days
mc.desktop 0000000113 113 Bytes about 6 years
mc.png 0000000923 923 Bytes almost 7 years
mc.spec 0000007471 7.3 KB 1 day
x11_browser 0000001720 1.68 KB over 8 years
xls2csv_update.patch 0000000582 582 Bytes over 1 year
Comments for mc 4

Илья Индиго's avatar

13ilya wrote about 1 year ago

Hello! mc is the only package on my system that needs "/usr/bin/python", while in the spec file I haven’t found what exactly it requires. Is it possible to save "mc" from this dependence or update the dependency to "/usr/bin/python3"?


Andre Barros's avatar

acobar wrote about 2 months ago

Can you apply a patch to stop the annoying subshell warning present on new version of mc?

You can find it on: https://salsa.debian.org/debian/mc/-/blob/master/debian/patches/4056.patch or check the committed change on https://github.com/MidnightCommander/mc/commit/8c243309ccae0528c0b59c2c45cd88d514ccfd90.

Please, do it.


Andre Barros's avatar

acobar wrote 7 days ago

Updated to newer package version, also 2 patches (mc-ext-audio.patch and mc-extd-sound.patch), and removed a patch applied upstream (mc-rpm.patch). Now mc builds appropriately.

See: https://build.opensuse.org/package/show/home:acobar:branches:Base:System/mc

Please, update to save others from the annoying subshell warning.


Adam Majer's avatar

adamm wrote 3 days ago

Can you do a submit request here then?