A KDE Photo Manager

digiKam is a simple digital photo management application for KDE, which
allows you to import and organize your digital photos easily. The
photos can be organized in albums, which can be sorted chronologically,
by directory layout, or by custom collections. An easy-to-use interface
that enables you to connect to your camera and preview, download, or
delete your images, is provided.

Refresh
Refresh
Source Files
Filename Size Changed
0001-Revert-Exiv2-is-now-released-with-exported-targets-u.patch 0000010237 10 KB 3 months
_constraints 0000000109 109 Bytes 2 months
digikam-7.1.0.tar.xz 0593501044 566 MB 25 days
digikam.changes 0000146371 143 KB 21 days
digikam.spec 0000008670 8.47 KB 25 days
Comments for digikam 5

Luz Paz's avatar

Kunda wrote over 1 year ago

Please update to digiKam 6.0


Wolfgang Bauer's avatar

wolfi323 wrote over 1 year ago

It's on the way: https://build.opensuse.org/request/show/679901

And JFYI: it's not always easy to do such a major version upgrade.
In this particular case, digikam 6.0 doesn't contain kipi-plugins anymore, but that's still used by other applications (spectacle, gwenview, kphotoalbum).
So we had to create a stand-alone kipi-plugins package first, and that had to go through legal review first where it was stuck for 11 days...


zy l's avatar

betamint wrote over 1 year ago

Today I tried to install digikam using zypper, but was surprised to find that it requires libKF5AkonadiContact5 (libKF5AkonadiContact.so.5), by requiring libdigikamcore6 (libdigikamcore.so.6.1.0).

After I told zypper to break the dependency on akonadi contact and installed digikam, it won't start, complaining "digikam: error while loading shared libraries: libKF5AkonadiContact.so.5: cannot open shared object file: No such file or directory".

It seems not reasonable that digikam as a photo management software should "require" akonadi contact. Is it possible to make akonadi contact only a "recommend" or "suggest" of digikam?


Christophe Giboudeaux's avatar

cgiboudeaux wrote over 1 year ago

Is it possible to make akonadi contact only a "recommend" or "suggest" of digikam?

No.


Fabian Vogt's avatar

Vogtinator wrote over 1 year ago

You need to raise that with the digikam authors. Currently if akonadi integration is enabled during buildtime, it's a hard runtime requirement as well.