Edit Package rstudio

RStudio

https://github.com/rstudio/rstudio

RStudio is a set of integrated tools designed to help you be more productive
with R.

It includes a console, syntax-highlighting editor that supports direct code
execution, and a variety of robust tools for plotting, viewing history,
debugging and managing your workspace.

Refresh
Refresh
Source Files (show merged sources derived from linked package)
Filename Size Changed
0001-Unbundle-mathjax-and-pandoc.patch 0000001545 1.51 KB 4 days
0002-Don-t-install-pandoc-and-mathjax.patch 0000002064 2.02 KB 4 days
0003-Fix-rstudio-exec-path.patch 0000000848 848 Bytes 9 months
0004-Add-additional-includes-for-aarch64.patch 0000001096 1.07 KB 9 months
0005-Use-system-hunspell.patch 0000001637 1.6 KB 9 months
0006-Fix-libclang-usage.patch 0000002201 2.15 KB 9 months
0007-use-system-node.patch 0000001469 1.43 KB 4 days
0008-Add-support-for-RapidJSON-1.1.0-in-Leap-15.2.patch 0000001283 1.25 KB 9 months
0009-Fix-catch-build.patch 0000000516 516 Bytes 7 months
_constraints 0000000293 293 Bytes almost 2 years
core-dictionaries.zip 0000876339 856 KB almost 9 years
nodejs-bundler.sh 0000001500 1.46 KB about 1 year
panmirror-0.1.0-bundled-licenses.txt 0000000150 150 Bytes 9 months
panmirror-0.1.0-nm.tgz 0043361173 41.4 MB 9 months
rstudio-rpmlintrc 0000000307 307 Bytes over 1 year
rstudio-server-user.conf 0000000112 112 Bytes over 2 years
rstudio.changes 0000018298 17.9 KB 4 days
rstudio.spec 0000023650 23.1 KB 2 days
v2022.02.2+485.tar.gz 0097661130 93.1 MB 4 days
Comments 7

Maikol Solis's avatar

mikesol wrote almost 2 years ago

Hi! I just installed this package in 15.2 and see that Rstudio 1.3 is not available.

Would you mind on update this package, please?

Best.


Dan Čermák's avatar

dancermak wrote almost 2 years ago

Sorry, but that is not possible. Leap 15.2 still has Boost 1.66 and RStudio 1.3 requires at least Boost 1.69. Unfortunately we cannot update Boost in Leap that easily and even less so, now that it is released.


Dan Čermák's avatar

dancermak wrote over 1 year ago

FYI, we (actually @adamm did) figured out that you can build rstudio with older boost versions just fine. So now the Leap 15.2 build is back.


Marco Varlese's avatar

mvarlese wrote over 1 year ago

That's great news! Thanks @adamm


Guillaume GARDET's avatar

Guillaume_G wrote over 1 year ago

Build error with boost 1.74 in Factory reported at https://github.com/rstudio/rstudio/issues/7706


Anonymous User's avatar

_nobody_ wrote over 1 year ago

This comment has been deleted


Dan Čermák's avatar

dancermak wrote over 1 year ago

I know, but unfortunately cherry picking that pull request resulted in a non-trivial amount of conflicts :-(

If you feel like going through with backporting it, you are most certainly welcome and can submit a pull request to https://github.com/dcermak/rstudio/tree/opensuse_patches. But I'm afraid I don't have the time for that.

openSUSE Build Service is sponsored by