LogoopenSUSE Build Service > Projects
Sign Up | Log In

Object-Oriented Graphics Rendering Engine
http://www.ogre3d.org/

OGRE (Object-Oriented Graphics Rendering Engine) is a scene-oriented, flexible 3D engine written in C++ designed to make it easier and more intuitive for developers to produce applications utilising hardware-accelerated 3D graphics. The class library abstracts all the details of using the underlying system libraries like Direct3D and OpenGL and provides an interface based on world objects and other intuitive classes.

Source Files (show merged sources derived from linked package)

Filename Size Changed Actions
fix-aarch64-detection.patch 1.15 KB Download File
fix-template-function.patch 4.74 KB Download File
ogre-1.9.0-fixsled.patch 1.2 KB Download File
ogre-1.9.0-longlongconstants.patch 3.75 KB Download File
ogre-1.9.0-texturearray-ambig-uint.patch 872 Bytes Download File
ogre.changes 16.2 KB Download File
ogre.spec 20.6 KB Download File
ogre1.9.0-browser-cmake.patch 1.26 KB Download File
v1-9-0.tar.bz2 122 MB

Comments for games (1)

repo-checker wrote 8 months ago

The version of this package in openSUSE:Factory has installation issues and may not be installable:

can't install libOgreMain-devel-1.9.0-3.5.i586:
  package libOgreMain-devel-1.9.0-3.5.i586 requires libOgreMain1_9_0 = 1.9.0, but none of the providers can be installed
  nothing provides libboost_system.so.1.67.0 needed by libOgreMain1_9_0-1.9.0-3.5.i586
  nothing provides libboost_thread.so.1.67.0 needed by libOgreMain1_9_0-1.9.0-3.5.i586

can't install libOgreMain-devel-1.9.0-3.5.x86_64:
  package libOgreMain-devel-1.9.0-3.5.x86_64 requires libOgreMain1_9_0 = 1.9.0, but none of the providers can be installed
  nothing provides libboost_system.so.1.67.0()(64bit) needed by libOgreMain1_9_0-1.9.0-3.5.x86_64
  nothing provides libboost_thread.so.1.67.0()(64bit) needed by libOgreMain1_9_0-1.9.0-3.5.x86_64

can't install libOgreMain1_9_0-1.9.0-3.5.i586:
  nothing provides libboost_system.so.1.67.0 needed by libOgreMain1_9_0-1.9.0-3.5.i586
  nothing provides libboost_thread.so.1.67.0 needed by libOgreMain1_9_0-1.9.0-3.5.i586

can't install libOgreMain1_9_0-1.9.0-3.5.x86_64:
  nothing provides libboost_system.so.1.67.0()(64bit) needed by libOgreMain1_9_0-1.9.0-3.5.x86_64
  nothing provides libboost_thread.so.1.67.0()(64bit) needed by libOgreMain1_9_0-1.9.0-3.5.x86_64

can't install libOgreMain1_9_0-plugins-1.9.0-3.5.i586:
  nothing provides libboost_system.so.1.67.0 needed by libOgreMain1_9_0-plugins-1.9.0-3.5.i586

can't install libOgreMain1_9_0-plugins-1.9.0-3.5.x86_64:
  nothing provides libboost_system.so.1.67.0()(64bit) needed by libOgreMain1_9_0-plugins-1.9.0-3.5.x86_64

can't install libOgreOverlay-devel-1.9.0-3.5.i586:
  package libOgreOverlay-devel-1.9.0-3.5.i586 requires libOgreOverlay1_9_0 = 1.9.0, but none of the providers can be installed
  nothing provides libboost_system.so.1.67.0 needed by libOgreOverlay1_9_0-1.9.0-3.5.i586

can't install libOgreOverlay-devel-1.9.0-3.5.x86_64:
  package libOgreOverlay-devel-1.9.0-3.5.x86_64 requires libOgreOverlay1_9_0 = 1.9.0, but none of the providers can be installed
  nothing provides libboost_system.so.1.67.0()(64bit) needed by libOgreOverlay1_9_0-1.9.0-3.5.x86_64

can't install libOgreOverlay1_9_0-1.9.0-3.5.i586:
  nothing provides libboost_system.so.1.67.0 needed by libOgreOverlay1_9_0-1.9.0-3.5.i586

can't install libOgreOverlay1_9_0-1.9.0-3.5.x86_64:
  nothing provides libboost_system.so.1.67.0()(64bit) needed by libOgreOverlay1_9_0-1.9.0-3.5.x86_64

can't install libOgrePaging-devel-1.9.0-3.5.i586:
  package libOgrePaging-devel-1.9.0-3.5.i586 requires libOgrePaging1_9_0 = 1.9.0, but none of the providers can be installed
  nothing provides libboost_system.so.1.67.0 needed by libOgrePaging1_9_0-1.9.0-3.5.i586

can't install libOgrePaging-devel-1.9.0-3.5.x86_64:
  package libOgrePaging-devel-1.9.0-3.5.x86_64 requires libOgrePaging1_9_0 = 1.9.0, but none of the providers can be installed
  nothing provides libboost_system.so.1.67.0()(64bit) needed by libOgrePaging1_9_0-1.9.0-3.5.x86_64

can't install libOgrePaging1_9_0-1.9.0-3.5.i586:
  nothing provides libboost_system.so.1.67.0 needed by libOgrePaging1_9_0-1.9.0-3.5.i586

can't install libOgrePaging1_9_0-1.9.0-3.5.x86_64:
  nothing provides libboost_system.so.1.67.0()(64bit) needed by libOgrePaging1_9_0-1.9.0-3.5.x86_64

can't install libOgreProperty-devel-1.9.0-3.5.i586:
  package libOgreProperty-devel-1.9.0-3.5.i586 requires pkgconfig(OGRE) = 1.9.0, but none of the providers can be installed
  package libOgreProperty-devel-1.9.0-3.5.i586 requires libOgreMain-devel, but none of the providers can be installed
  package libOgreMain-devel-1.9.0-3.5.i586 requires libOgreMain1_9_0 = 1.9.0, but none of the providers can be installed
  nothing provides libboost_system.so.1.67.0 needed by libOgreMain1_9_0-1.9.0-3.5.i586
  nothing provides libboost_thread.so.1.67.0 needed by libOgreMain1_9_0-1.9.0-3.5.i586

can't install libOgreProperty-devel-1.9.0-3.5.x86_64:
  package libOgreProperty-devel-1.9.0-3.5.x86_64 requires libOgreMain-devel, but none of the providers can be installed
  package libOgreProperty-devel-1.9.0-3.5.x86_64 requires pkgconfig(OGRE) = 1.9.0, but none of the providers can be installed
  package libOgreMain-devel-1.9.0-3.5.x86_64 requires libOgreMain1_9_0 = 1.9.0, but none of the providers can be installed
  nothing provides libboost_system.so.1.67.0()(64bit) needed by libOgreMain1_9_0-1.9.0-3.5.x86_64
  nothing provides libboost_thread.so.1.67.0()(64bit) needed by libOgreMain1_9_0-1.9.0-3.5.x86_64

can't install libOgreProperty1_9_0-1.9.0-3.5.i586:
  package libOgreProperty1_9_0-1.9.0-3.5.i586 requires libOgreMain.so.1.9.0, but none of the providers can be installed
  nothing provides libboost_system.so.1.67.0 needed by libOgreMain1_9_0-1.9.0-3.5.i586
  nothing provides libboost_thread.so.1.67.0 needed by libOgreMain1_9_0-1.9.0-3.5.i586

can't install libOgreProperty1_9_0-1.9.0-3.5.x86_64:
  package libOgreProperty1_9_0-1.9.0-3.5.x86_64 requires libOgreMain.so.1.9.0()(64bit), but none of the providers can be installed
  nothing provides libboost_system.so.1.67.0()(64bit) needed by libOgreMain1_9_0-1.9.0-3.5.x86_64
  nothing provides libboost_thread.so.1.67.0()(64bit) needed by libOgreMain1_9_0-1.9.0-3.5.x86_64

can't install libOgreRTShaderSystem-devel-1.9.0-3.5.i586:
  package libOgreRTShaderSystem-devel-1.9.0-3.5.i586 requires libOgreRTShaderSystem1_9_0 = 1.9.0, but none of the providers can be installed
  nothing provides libboost_system.so.1.67.0 needed by libOgreRTShaderSystem1_9_0-1.9.0-3.5.i586

can't install libOgreRTShaderSystem-devel-1.9.0-3.5.x86_64:
  package libOgreRTShaderSystem-devel-1.9.0-3.5.x86_64 requires libOgreRTShaderSystem1_9_0 = 1.9.0, but none of the providers can be installed
  nothing provides libboost_system.so.1.67.0()(64bit) needed by libOgreRTShaderSystem1_9_0-1.9.0-3.5.x86_64

can't install libOgreRTShaderSystem1_9_0-1.9.0-3.5.i586:
  nothing provides libboost_system.so.1.67.0 needed by libOgreRTShaderSystem1_9_0-1.9.0-3.5.i586

can't install libOgreRTShaderSystem1_9_0-1.9.0-3.5.x86_64:
  nothing provides libboost_system.so.1.67.0()(64bit) needed by libOgreRTShaderSystem1_9_0-1.9.0-3.5.x86_64

can't install libOgreTerrain-devel-1.9.0-3.5.i586:
  package libOgreTerrain-devel-1.9.0-3.5.i586 requires libOgreTerrain1_9_0 = 1.9.0, but none of the providers can be installed
  nothing provides libboost_system.so.1.67.0 needed by libOgreTerrain1_9_0-1.9.0-3.5.i586
  nothing provides libboost_chrono.so.1.67.0 needed by libOgreTerrain1_9_0-1.9.0-3.5.i586
  nothing provides libboost_thread.so.1.67.0 needed by libOgreTerrain1_9_0-1.9.0-3.5.i586

can't install libOgreTerrain-devel-1.9.0-3.5.x86_64:
  package libOgreTerrain-devel-1.9.0-3.5.x86_64 requires libOgreTerrain1_9_0 = 1.9.0, but none of the providers can be installed
  nothing provides libboost_system.so.1.67.0()(64bit) needed by libOgreTerrain1_9_0-1.9.0-3.5.x86_64
  nothing provides libboost_chrono.so.1.67.0()(64bit) needed by libOgreTerrain1_9_0-1.9.0-3.5.x86_64
  nothing provides libboost_thread.so.1.67.0()(64bit) needed by libOgreTerrain1_9_0-1.9.0-3.5.x86_64

can't install libOgreTerrain1_9_0-1.9.0-3.5.i586:
  nothing provides libboost_system.so.1.67.0 needed by libOgreTerrain1_9_0-1.9.0-3.5.i586
  nothing provides libboost_chrono.so.1.67.0 needed by libOgreTerrain1_9_0-1.9.0-3.5.i586
  nothing provides libboost_thread.so.1.67.0 needed by libOgreTerrain1_9_0-1.9.0-3.5.i586

can't install libOgreTerrain1_9_0-1.9.0-3.5.x86_64:
  nothing provides libboost_system.so.1.67.0()(64bit) needed by libOgreTerrain1_9_0-1.9.0-3.5.x86_64
  nothing provides libboost_chrono.so.1.67.0()(64bit) needed by libOgreTerrain1_9_0-1.9.0-3.5.x86_64
  nothing provides libboost_thread.so.1.67.0()(64bit) needed by libOgreTerrain1_9_0-1.9.0-3.5.x86_64

can't install libOgreVolume-devel-1.9.0-3.5.i586:
  package libOgreVolume-devel-1.9.0-3.5.i586 requires libOgreVolume1_9_0 = 1.9.0, but none of the providers can be installed
  nothing provides libboost_system.so.1.67.0 needed by libOgreVolume1_9_0-1.9.0-3.5.i586
  nothing provides libboost_chrono.so.1.67.0 needed by libOgreVolume1_9_0-1.9.0-3.5.i586
  nothing provides libboost_thread.so.1.67.0 needed by libOgreVolume1_9_0-1.9.0-3.5.i586

can't install libOgreVolume-devel-1.9.0-3.5.x86_64:
  package libOgreVolume-devel-1.9.0-3.5.x86_64 requires libOgreVolume1_9_0 = 1.9.0, but none of the providers can be installed
  nothing provides libboost_system.so.1.67.0()(64bit) needed by libOgreVolume1_9_0-1.9.0-3.5.x86_64
  nothing provides libboost_chrono.so.1.67.0()(64bit) needed by libOgreVolume1_9_0-1.9.0-3.5.x86_64
  nothing provides libboost_thread.so.1.67.0()(64bit) needed by libOgreVolume1_9_0-1.9.0-3.5.x86_64

can't install libOgreVolume1_9_0-1.9.0-3.5.i586:
  nothing provides libboost_system.so.1.67.0 needed by libOgreVolume1_9_0-1.9.0-3.5.i586
  nothing provides libboost_chrono.so.1.67.0 needed by libOgreVolume1_9_0-1.9.0-3.5.i586
  nothing provides libboost_thread.so.1.67.0 needed by libOgreVolume1_9_0-1.9.0-3.5.i586

can't install libOgreVolume1_9_0-1.9.0-3.5.x86_64:
  nothing provides libboost_system.so.1.67.0()(64bit) needed by libOgreVolume1_9_0-1.9.0-3.5.x86_64
  nothing provides libboost_chrono.so.1.67.0()(64bit) needed by libOgreVolume1_9_0-1.9.0-3.5.x86_64
  nothing provides libboost_thread.so.1.67.0()(64bit) needed by libOgreVolume1_9_0-1.9.0-3.5.x86_64

can't install ogre-demos-1.9.0-3.5.i586:
  nothing provides libboost_system.so.1.67.0 needed by ogre-demos-1.9.0-3.5.i586

can't install ogre-demos-1.9.0-3.5.x86_64:
  nothing provides libboost_system.so.1.67.0()(64bit) needed by ogre-demos-1.9.0-3.5.x86_64

can't install ogre-demos-devel-1.9.0-3.5.i586:
  package ogre-demos-devel-1.9.0-3.5.i586 requires libOgreMain-devel = 1.9.0, but none of the providers can be installed
  package libOgreMain-devel-1.9.0-3.5.i586 requires libOgreMain1_9_0 = 1.9.0, but none of the providers can be installed
  nothing provides libboost_system.so.1.67.0 needed by libOgreMain1_9_0-1.9.0-3.5.i586
  nothing provides libboost_thread.so.1.67.0 needed by libOgreMain1_9_0-1.9.0-3.5.i586

can't install ogre-demos-devel-1.9.0-3.5.x86_64:
  package ogre-demos-devel-1.9.0-3.5.x86_64 requires libOgreMain-devel = 1.9.0, but none of the providers can be installed
  package libOgreMain-devel-1.9.0-3.5.x86_64 requires libOgreMain1_9_0 = 1.9.0, but none of the providers can be installed
  nothing provides libboost_system.so.1.67.0()(64bit) needed by libOgreMain1_9_0-1.9.0-3.5.x86_64
  nothing provides libboost_thread.so.1.67.0()(64bit) needed by libOgreMain1_9_0-1.9.0-3.5.x86_64

can't install ogre-tools-1.9.0-3.5.i586:
  nothing provides libboost_system.so.1.67.0 needed by ogre-tools-1.9.0-3.5.i586

can't install ogre-tools-1.9.0-3.5.x86_64:
  nothing provides libboost_system.so.1.67.0()(64bit) needed by ogre-tools-1.9.0-3.5.x86_64

Login required, please login or signup in order to comment